operation not allowed

7 thoughts on “operation not allowed

  1. Hi,


    I tried to check whether GPRS is attached (command AT+CGATT?) and in the case the response is +CGATT: 0 I send a command AT+CGATT=1 which sometimes failes with response 

    +CME ERROR: operation not allowed


    After I retry this commands few times it usually works with expected result +CGATT: 1

     Firmware version I am using is 7.02.606


    What might be wrong?

    1. Hi Roman, please check first SIM/PIN status (+CPIN), registration (+CREG), signal (#SERVINFO). Verify if GPRS attach is automatic or not (#AUTOATT), if yes your command might interfere with auto attachment.

  2. Thanks


    the command #AUTOATT seems to be the one (it was set to 1 by default).


    I have now some other problem, after the modem succesfully receive an IP address 

    I try to make connection to local web server using command AT#SKTD. 

    This sometimes works (reply CONNECT) but occasionaly i get only ‘r’ character and nothing more.

    1. Some update:


      I have tried the same application with two different modems (altough both with the same firmware 7.02.606) and this problem is only on one of them, so maybe its a defective one..

      1. Maybe there are some different settings between them? Have them "factory reset" with a fresh firmware reload and re-test.

        1. Hi,


          I have the problem solved now, but maybe in the future it will help someone else, so the problem was in our HW design, where we have left the RTS signal floating, which in data mode (after CONNECT) caused blocking behaviour sometimes (HW flow is enabled by default)

          So grounding this signal or issuing AT&K0 should help (it did in my case anyway).

          1. Thanks Roman, good to know you solve it; Hardware User Guide specify RTS has no pull-up resistor and cannot be left floating.