Updating GL865 DUAL V3 firmware – no connection

3 thoughts on “Updating GL865 DUAL V3 firmware – no connection

  1. Hello!


    I am currently trying to update the firmware of a GL865 DUAL V3 module. The module is installed on an embedded system and I cannot get the module to communicate. I am using xfp and the SW version that I want to install is 16.00.153 


    I have already successfully updated the firmware using a EVK2 Test Board. But in this case I cannot seem to get it to work. I have tried using the TXD and RXD pins as well as the AUX_TXD and AUX_RXD pins. These are connected to a COM port on a PC. I can communicate using AT commands without any problems, but every time I try a firmware update then I get the following error :




    ERROR – FlashSendStream  – Error rx (0x000001EE – 0x000101ED), code -65 (-9).


    I think that what’s happening is that the module simply does not reply. Should I use other pins for programming? Are there pins that should be tied low/high for the operation? Again the AT commands seem to work fine. 


    If anybody can help out with this, then it would be much appreciated.






    1. Try with another PC and the latest XFP.

      The EVK2 uses the same pins so should work. Maybe there are problems with your board UART level shifters (too slow)? 

      1. Hello!


        I managed to solve the problem finally by using a USB->COM port converter. I do not know why it worked, but fortunately it did.