Telit Python and Windows XP COM port issues

12 thoughts on “Telit Python and Windows XP COM port issues

  1. Hi Guys,


    I’m a bit of a newbie to this, but i’ve taught my self a few tricks, so please rock me gently.Laughing


    For about 5weeks now, I’ve been struggling to get Telit Python and EZ-10 GPS to execute a code involving SER and MDM on Windows XP.


    The porgrams works great on my laptop running Windows 7 starter Edit but not on my desktop running Windows XP SP2.


    It seems as if the script can’t find a COM port as there are no conflict issues if i try to open hyper terminal or RS term when the python script is already open.


    Interestingly, hyper terminal and RS term communicate fine with the EZ-10 GPS modem, but the python script with MDM and SER modules gives error when attempting COMS with the modem and works well if the SER and MDM commands are removed/disabled.


    It doesn’t looks like a COM conflict issue!! but maybe a python directory or setup path issues. It’s neither a cable or hardware issue. I’m using Telit Python 1.5.2 ++ package.


    Attached is the error message and any tips or green light will be appreciated.




      1. Thanks for the reply


        Yes, i followed the same working setup (using the Telit COM port selection tool and selecting the appropriate COM port) as on my laptop running Windows 7 starter except there is a special setup which i’m not aware of.


        Please let me know. 

        1. You can check again with "Telit COM port selection tool" available in Start menu, or directly look in C:Program and C:Program


          1. Thanks Cosmin for the reply,


            I’ve been ensuring the COM port that the modem is connected to is always the same as that on Telit COM port selection tool since April and to no avail to date.Embarassed


             Also the SER and MDM files are also present in the Python lib folder.


            What i can tell and is frustrating me is the COM port doesn’t seems to be detected only if i tried acessing it using pythonwin. There is no conflict message (beside the attribute errors in the interactive window) if i tried to run a python script on the same COM port already busy  with another application or vice versa.


            Also if i open the COM port select tool on pythonwin menu bar, it spits out error messages (see attached) but if i open the choice file before or after selecting the COM port select tool in pythonwin, then it doesn’t complaint anymore about the import choice execution error (mssing file error) but still only about the attribute error.


            I’ve re-installed the Telit Python 1.5.2 + software and restarted my machine but to avail.Frown


             The attached file will give an idea of the issues i’m experriencing, maybe you can interprete what it means and give me the right pointers. 


            As for now, i can only use my laptop running Windows 7 starter edit but i’ll really appreciate if you can get this to wrok on my desktop running Windows XP SP2.





          2. Something is screwed in your installation, try to do a complete uninstall, clean path variables, re-install. Check path variables again.


          3. Thanks for the feedback Cosmin;


            This issue is drving me nuts as i’ve even re-installed Telit pythonwin on a different diretcory and drive but still having the same issue. I’ve even cross check the path and all the install items and everything is the same as on my laptop running Windows 7 starter (I wish it was possible to downgrade my windows 7 to XP SP2 just to see if it will make any difference). Except i just have to reinstall the Windows XP SP2 OS which i don’t think i’ll.


            Just for interest sake, is it possible for you to do me a favour and install Telit pythonwin 1.5.2+ on a machine running Windows XP SP2 to see if you can experience and simulate the issue i’ve been having?



          4. Hi Paul, my regular work machine is XP SP2 and have no problems with it; I must reckon i am not using much SER/MDM from PC lately, doing all debugging on the module itself, is much cleaner and faster.

          5. Try the following things:


            1. move your files somewhere in your Python installation, in Example folder perhaps (C:Program FilesPythonExamples or whatever is). Test it, opening fresh Pythonwin.


            2. close Pythonwin, go in Python Lib folder (C:Program FilesPythonLib or whatever is) and delete SER.pyc (not !). Restart Pythonwin and try your file.


            Remember if everything is correct typing "SER." should show up code completition suggestions, available functions, its parameters after opening ( etc.

          6. Thanks for the heads-up Cosmin,


            If you say you’ve been using Windows XP SP2 then there is something i’m not doing correctly whih i doubt. Undecided I’ve even got up 6a:m in the morning when i’m still fresh and start  afresh from scratch but to no avail. Maybe i should request a friend to try also.Laughing


            Nonetheless, i’ll try your advice and see how it goes if not, i’ll move on using my laptop.


            Just for curiousity sake, can you please explain what u meant by  "doing all debugging on the module itself". How?



          7. Just for curiousity sake, can you please explain what u meant by  "doing all debugging on the module itself". How?


            … running the programs on module and having placed inspection points in needed places, presenting info via print/debug console on dedicated port, CMUX or a free SER.

  2. Thanks for the feedback Cosmin.


    Ahh, i see what you mean. I usually do the same but only when i know the code is first working in pythonwin (so called good testing practice); which most of the time pythonwin always stop responding after a couple of prints; even if the script has no MDM or SER commands.   You’re expert already, so you can do direct debug on the module.Smile 


    For interest sake,  if i download the code then debug it on the module via CMUX on my PC running XP SP2, it works great!!! but if i open and debug same script via print then i’ve all the COM port communication hassles!!!


    Well, talking about debug via CMUX and print; oops i think i better start a new thread under the appropriate section. Please refer to CMUx section regarding my question..