Telit evk2 connection problem

5 thoughts on “Telit evk2 connection problem

  1. I have a MAC that I installed VM with windows XP on it and furthermore installed the FTDI VCP drivers. When I connect my board, I see four connections COM21,COM22,COM22,COM23 (for some reason there are two COM22).


    The problem is that when I select any combination of COM ports, still my PyWin tools can not download any of my programs into it. Can anybody shed some light as how I can see if device drivers are OK or if there is any chance I can debug my connection using hyperterminal.


    By the way, what is the virtual COM serial configuration, baudrate, hardware flow and so forth….


    Thank you 

    1. I’m afraid is hard to give much help for a Mac, when even on Windows these USB to serial adapters have varying quality and driver problem. Can you detail all the steps involved in installation procedures, on MAC then Windows? What exact VM, OSX version, adapter type and drivers.

      Can you communicate with the module with a terminal application in OSX and Windows?


  2. I have a combination of EVK2 kit, CC/UC/GC864 INT interface card and GC864-SIM-V2 module. I have a MAC OSX 10.6.6 which runs VMware fusion that hosts Windows XP. 

    • I installed the FTDI VCP drivers (Windows 2010-08-11 2.08.02) from on my windows
    • I also googled for TelitPy1.5.2+_V4.1.exe (no CD came with the board) and installed it on my windows from:
    • When I connect my Telit evk2 USB to my MAC, the VM askes if I want to connect it to VM and I confirm it. Then I see four COM ports COM21, COM22, COM22, COM23 on My windows machine. On windows device manager when I select those devices and choose properties, It says the device is working properly.
    • On PythonWin, when I choose Tools/Telit Module Script Download/Download to download a python script to the module, I always get the message:                     The COM port is busy! Please Verify that It is not used by another application      and retry. Retry?
    • I have tried many combination of those ports for MDM Emulation, Serial Emulation … and non worked.
    If you think I need a standalone Windows machine, I will try to get one. It is just that XP is a bit old now…. Your help is very much appriciated.
    Thank you
  3. I have made it work in several minutes, here is the procedure:


    1. On MACOS X 10.6.7, Oracle Virtalbox 4.0.4 r70112

    – download MACOS FTDI drivers from FTDI

    – install the drivers, check /dev for correct devices presence (see installation doc from FTDI)

    – power on EVK2 and connect to USB

    – test communication with the modem, worked on port "usbserial-00004106B" with CoolTerm

    – close CoolTerm


    2. Start Virtualbox, do not start the VM

    – in VM settings, Ports tab, USB:

        enable USB controller

        enable USB 2.0 (EHCI) controller

        in Device Filters add the two items: Telit Data Module EVK2-0, Telit Data Module EVK2-1 (click the little plug with a green + on the right and select the devices)

    – start VM


    3. In Windows XP

    – New Hardware window will appear after startup, leave it untouched

    – download Windows drivers from FTDI

    – proceed with installation in New Hardware window, pointing to the folder of the just downloaded drivers (unzip)

    – check 4 serial ports appear in Device Manager, COM3 to COM6

    – check communication with a serial terminal like Hyperterminal or rsterm, worked here with COM4





    1. Well. I am am using vmware and I followed up a little variant of what you say. In my case, the key thing was that during the driver installation, I had to make the VM disconnected from the network so that windows ask me if I want to install drivers from local directory. Then I pointed windows to the FTDI driver I downloaded and things started to work as you indicated.

      Thank you for the awsome feedback