[SOLVED] Unable to upgrade UL865

8 thoughts on “[SOLVED] Unable to upgrade UL865

  1. I’m having problems upgrading a UL865 running 12.00.603-B036 using Xfp over USB. I have tried all 4 virtual ports but it’s always stuck at "Linking…." until it times out with error code -4.


    I assume that I should use the same procedure as UC (plug in -> power on -> upgrade) even though the UL series is not listed there, correct?

    1. What XFP version have you?


      The procedure is not as for UC but for the rest, ie first click Program then power on the module – experiment with various power on button press durations.

      1. Not sure which version I have, to be honest 😀 It seems like theres no way of telling from within the application.


         Can it be upgraded via USB though? I need to have it powered in order for the ports to be available to the OS so I can open them in Xfp, right?

        1. Do you use an telit evaluation kit or a your application?

          Do you use the micro USB of the interface board or do you use the USB of the EVK?

          What’s the name of binary file used? 


          let me know.. 

  2. This is on an EVK2. I have tried using both the USB of the EVK (not the micro of the UL865 module) and the two serial ports, though I’m not sure if the cable was correct.


    The binary I’m trying to flash is stream_UL865_EUR-12.00.604.bin. 

    Edit: Xfp ver is 2.0.23 and "TDK" ver is 2.0.38.
    1. I managed to upgrade the device using the following steps:


      1) Install HE910 drivers provided by Telit 

      2) Use the micro USB port on the UL865 card, NOT the large USB port on the EVK itself

      3) Enter ‘USB’ as port

      4) Follow the on screen instructions for upgrading via USB


  3. Hello,


    I have recently buy two UL865 evaluation boards and I am running some tests. 

    However, the firmware version of the modules is deprecated (12.00.603-B036) and I don’t have access to some recent functionnalities.


    The problem is I can’t find anywhere on the Download Zone any firmware for the UL865. I’am very surprised by what Marco said regarding its stream_UL865_EUR-12.00.604.bin firmware stream because there is no such stream on the download zone, there are only some streams for the HE910 and the UE910 (the version seems good, 12.00.xx5 but not adapted for the UL865). I tried to upload the12.00.xx5 firmware on one of my modules but it doesn’t work at all…


    Could you please keep me in touch in order to tell me where I should find the proper firmware version for the UL865?




    Jean-Baptiste Quesnel