[SOLVED] Mis-uploaded script, unit bricked?

4 thoughts on “[SOLVED] Mis-uploaded script, unit bricked?

  1. After struggling with getting the Python script upload function to work (faulty flow control on Atmel UC3) on a GL865 chip I finally managed to upload something to the device. The problem was that during testing of both .py and .pyo I accidentally changed the upload type to .py but uploaded the .pyo script. The faulty script was set as the active one and executed. Now I can no longer access the unit via AT commands.


    So far I have tried to both set DTR low and high before rebooting, but I still cannot communicate with the module. Is it bricked or is there some way to block it from executing regardless of what STARTMODESCR is set to? Or is there a way of clearing the NVM without AT commands?


    1. The biggest chance to succeed is to perform a firmware upload with the PC XFP tool.

  2. Turns out it wasn’t bricked at all. I had just accidentally enabled flow control again, so no data was received when I tried to read from the USART.