GL865-QUAD AT#FTPLIST freeze

7 thoughts on “GL865-QUAD AT#FTPLIST freeze

  1. Hello!

     

    I’m having trouble with AT#FTPLIST-command. We’ve previously written an update procedure on GE865-QUAD with firmware 10.00.007 on which the command works. I am now porting this code to GL865-QUAD with firmware 10.00.146.

     

    I’ve successfully registered to the network, opened a GPRS-connection and a passive mode FTP connection to our test servers. When I run AT#FTPLIST on the module,  it prints a single empty line and stops responding afterwards. The only way to recover is to reset power to the module.

     

    AT commands issued:

     

     

    at#gprs=1

     

    +IP: 80.186.179.243

     

    OK

    at#ftpopen=glonass.fi:8021,devtest,DfeT#21!%x,1

     

    OK

    at#ftplist=/home/test/test

     

     

     

    FTP server log:

     

     

     Mon Jun 10 11:50:21 2013 [pid 2] CONNECT: Client "80.186.179.243"

    Mon Jun 10 11:50:21 2013 [pid 2] FTP response: Client "80.186.179.243", "220 (vsFTPd 2.3.2)"

    Mon Jun 10 11:50:22 2013 [pid 2] FTP command: Client "80.186.179.243", "USER devtest"

    Mon Jun 10 11:50:22 2013 [pid 2] [devtest] FTP response: Client "80.186.179.243", "331 Please specify the password."

    Mon Jun 10 11:50:22 2013 [pid 2] [devtest] FTP command: Client "80.186.179.243", "PASS "

    Mon Jun 10 11:50:24 2013 [pid 1] [devtest] OK LOGIN: Client "80.186.179.243"

    Mon Jun 10 11:50:24 2013 [pid 3] [devtest] FTP response: Client "80.186.179.243", "230 Login successful."

    Mon Jun 10 11:50:42 2013 [pid 3] [devtest] FTP command: Client "80.186.179.243", "PASV"

    Mon Jun 10 11:50:42 2013 [pid 3] [devtest] FTP response: Client "80.186.179.243", "227 Entering Passive Mode (31,217,192,34,137,250)."

    Mon Jun 10 11:50:43 2013 [pid 3] [devtest] FTP command: Client "80.186.179.243", "LIST /home/test/test"

    Mon Jun 10 11:50:43 2013 [pid 3] [devtest] FTP response: Client "80.186.179.243", "150 Here comes the directory listing."

    Mon Jun 10 11:50:44 2013 [pid 3] [devtest] FTP response: Client "80.186.179.243", "226 Directory send OK."

    Mon Jun 10 11:55:44 2013 [pid 3] [devtest] FTP response: Client "80.186.179.243", "421 Timeout."

     

    Module: GL865-QUAD

    Firmware: 10.00.146

     

    Do you have any idea and advice as to why this is occurring? 

     

     

    1. I sent you a download link for 10.00.147, can you upgrade and try with that?

       

      Thanks!

          1. Hi Cosmin,

             

            Thanks for the link. The behaviour was exactly the same but I managed to get it working by issuing AT&K0. Now the module produces a file list as before.

             

            As a side note, could you send me a download link for the change log of the 10.00.147 firmware, so I can review what has changed?

             

            Thanks!