GE865-QUAD FTP and Socket problems

3 thoughts on “GE865-QUAD FTP and Socket problems

  1. Hi,

     

    After upgrading GE865-QUAD firmware to 10.00.006 we’ve started getting a lot of DNS query errors when attempting to open a socket in command mode using AT#SD.

     

    Socket is configured as follows:

    AT#SCFG=1,1,300,0,300,0

    AT#SCFGEXT=1,2,0,0,0

     

    Socket is opened as follows 

    AT#SD=1,0,xxxx,xxxx,0,0,1

    +CME Error: Cannot resolve DN

     

    Sometimes it’s resolved by deactivating and reactivating GPRS context via AT#GPRS=0, AT#GPRS=1. We have tried both with AT#CACHEDNS on and off, but this seems to have no effect. We have used firmwares 10.00.004 and 10.00.005 successfully without ever noticing this behaviour Any ideas if this has something to do with the new firmware?

     

    Also, recently we’ve started to get errors with FTP.  We have a basic FTP server and we’re accessing it as follows:

     

    AT#FTPOPEN=ourserver:ourport,uname,pw,1

    +CME Error: Can not connect control socket

     

    Other than that the FTP settings are module defaults. 

    1. Is this related with some geographic locations only? GSM signals are as before? Can you downgrade a module to positively put a question mark on  10.00.006?

       

      1. Is this related with some geographic locations only? GSM signals are as before? Can you downgrade a module to positively put a question mark on  10.00.006?

         

        Hi Cosmin,

         

        We’ve had these issues in two different countries. I just did a quick test on my desk with one module running 10.00.005 and another one with 10.00.006. The older firmware had zero issues while the newer one could not get a socket open until I deactivated GPRS and reactivated it (AT#GPRS=0, AT#GPRS=1). Both modules used sim cards from the same operator with identical settings. Both report a good signal quality (-48dbm).