Legacy Python 1.5.2+