Socket connection hangs GE864 module

6 thoughts on “Socket connection hangs GE864 module

  1. I have a GE864-GPS engineering sample on the EVK2 board and running firmware:
    It is on the T-mobile network via the reseller Raco. The tower I am connected to is:
    #SERVINFO: 723,-74,"T-Mobile","31026",50,A16E,01,1,,"II",1A,6
    The signal strength appears to be good:
    +CSQ: 21,0
    I setup the connection context:
    and set the socket configuration
    Then I open the connection
    When I try to make an IP socket connection to my server, it times out after a minute
    and, even more mysteriously, if I try to connect to port 80 the command hangs forever and the only way to recover is a hardware reset.
    also tried
    but it also hangs and never times out.
    Can you help me narrow down the problem?
    Thanks in advance,
    1. Set AT+CMEE=2 for verbose messages and check again.

      If you are not using hardware flow control on the serial port set AT&K0.

      1. Setting AT&K0 helped a lot. Thanks.

        I can now conect to port 80 on external websites and port 8080 on my server.


        But when attempting a connection to port 27421 on my server I get the extended error message:


        +CME ERROR: timeout in opening socket


        Is there any restriction on the port numbers that the Telit module can use? Do you know if T-mobile in the US filters certain ports? I chose 27421 as it appeared to be unused by any other service.

        I will try reconfiguring my server to use a lower port number to see if that is the problem. 



    I moved the server service to port 21 but I still get the same result. I can connect to a web server running on port 8080 but not to the service running on port21. I am certain that the service on port 21 is running and accepting connections from a test program on my PC, just not from my Telit module.

    Any commands that would give me more insight into the problem would be much appreciated.



    1. Is your PC on the same network as the server? Check the router’s forwarding/tunneling rules, maybe they are not set correctly.

      Telit modules have no limitations in addressing ports, but mobile networks can impose such so check with them.


      1. With the help of our data provider I found that the APN set in the AT+CGDCONT must have a special value to allow T-Mobile to route the traffic correctly.


        So everything works as expected now and this issue can be closed.


        Thanks for your help