SIM failure

7 thoughts on “SIM failure

  1. Hi everyone, 


    I built a development board for the UC864E. I use the rsterm to test the device. When I issue the  AT+CPIN=? command I get the following error +CMEE ERROR : sim failure. I checked the connections of the SIM card and they are correct. Is there any problem with the capacitors? I followed the instructions from the datassheet.


    Thank you in adance



    1. Hi Panos


      Nice to see someone from Finland on this forum 🙂


      Could it be that your SIM is not detected? To be sure, you can always issue the forcing AT-command AT#SIMDET=1.


      BR, Tom

      1. Hi Tom 


        I am acctually from Greece but I am here for studies.:-) 

        At first I had this error "SIM not detected" but it was because I had mistaken the connections. I did try the SIMDET command but when I am trying to type in the PIN I get the error "operation is not allowed" . I dont know what to do next.


        Best regards


  2. I see. Maybe take the SIM card out from your development board, insert it into a mobile phone and then disable the PIN there.  Then it should work on the development board as well, although the original reason for your problem could not be solved in this way.



    1. Tom I did as you said but still I get the same error. I tried the SIMDET do bypass the SIM but after that I get 0,0 when I type the CREG command. I attached a picture with the results



        1. Take a look in "SIM HOLDER DESIGN GUIDES Application Note"  doc, maybe will bring some help?