LE70-868: UART Problems

8 thoughts on “LE70-868: UART Problems

  1. Hello,

    I use 2 LE70 in a point to point link between 2 computers.

    Radio baud Rate=38.4kbps

    Serial link=9600bps

    Band: g3.

    Power: +27dBm

     

    I have developped a board that only powers the NE70 and converts RS232 signal to TTL signal.

    Power is clean the serial link is ok: I use it to configure NE70.

     

    A program asks every 5 seconds  the other computer to get local data.

    Request: 8 bytes

    Response: 32 bytes

     

    Problem:

    From 2 hours to some days, the link is broken: I need to reset 1 or the 2 modules because the serial frame is not transmitted on the air.

     

    Sometimes, the NE70 sends back to the computer the request via the serial link.

     It seems to be a bug with serial buffer with a 256 bytes length, but I don’t find a solution.

     

    Thanks for your help.

    CB.

     

    1. Hi

      sorry, but are you speaking about LE70 (as indicated into subject) or NE70?

      In any case could you tell me module FW version, module setting and send me a description of your test?

      Thanks

      1. Hi,

        It is a mistake: I only use LE70-868.

        FW Version: GJ.S00.02.04-B007

         

        Transparent Mode

         

        Radio:

         – Output Power: 27dbm

         – Radio Baud Rate 38.4Kbps

         – Bnd g3

         – Carrier length = 20

         – Radio Whitenning character = 170

         – Channel 0

         

        Serial link:

         – 9600bit/s / 1bit stop / Parity None /  8 data bits

         – No Flow Control

         – TimeOut = 5ms

         – No Synch word

         

        TESTS:

        A radio link between 2 computers: Master / Slave.

        A program on the MASTER asks every 5 seconds  the SLAVE to get local data.

        A program on the SLAVE reply only if the Master request is received correctly.

        Request: 8 bytes   (Sent by Master)

        Response: 32 bytes (Sent by Slave)

         

        Problem:

        From
        2 hours to some days, the link is broken: I need to reset 1 or the 2
        modules because the serial frame is not transmitted on the air.

         

        Sometimes, the LE70 sends back to the computer the request via the serial link.

         It seems to be a bug with serial buffer with a 256 bytes length, but I don’t find a solution.

         

        Thanks for your help.

        CB.

        1. Hi,

          could you download latest SW version attached?

          Do you use our demokit? if yes, please refer to SRmanager tool user  guide in order to get flashing instruction

          If you do not use demokit you have to follow the instruction as below:

          Local module and flashing via serial cable.

          Procedure with TX, RX, GND pin only:

           

                
          Start the module

                
          Use a basic terminal software to send ‘+++’ and wait for ‘OK<CR>’
          reply. (Default config is 19200 8N1, if no response is coming back, try all
          serial speed from 1200 to 115200 until receiving OK).

                
          Still using the terminal send ‘ATBL<CR>’ and wait for
          ‘OK<CR>’ reply. ATBL is need to put module in Program mode.

                
          Launch SRManager tool utility and flash the module.

          (here you are SRMANAGER tool: https://tcloud.telit.com/public.php?service=files&t=2aa7371e49a29bdd2aa8b6d477be6378)

           

           

           

          Note: <CR> is for Carriage Return,
          0x0D character.

           

          Please refer to schematic at the end of doc
          for info about HW connection.

          1. Hi,

            Thanks for your reply.

            I upgraded SW with GJ.S00.02.05-B001.

            Could you give me some informations about this release?

             

            At this moment, 5 LE70-868 are being tested:

             – 1 is Master (Pc with program)

             – 4 are Slaves and transmit data when requested by the Master

             

            We will see on monday if the release is efficient.

             

            Best Regards,

            C. Brazeilles.

             

             

             

          2. Hi,

            This morning, the 4 LE70 are still working: no bug this week-end.

            I am not sure that everything is resolved: problems may appear in a few days, as with the previous firmware.

            Could you give me informations about this now firmware: GJ.S00.02.05-B001.

             Why can’t we find thisnew firmware on the download zone?

             

            Best Regards,

            C. Brazeilles.

             

          3. Hi
            This Sw is more stable about serial link, it is a beta version, so for this reason you do not find it.
            As soon as it will become an official version it will be on web site.