#SGACT 1,1 end with activation failed

11 thoughts on “#SGACT 1,1 end with activation failed

  1. Hello,


    I have a strange Activation failed error :

    I created a simple program supposed to do :


    AT+CGDCONT=1, “IP”,”internet66″







    +CME ERROR: activation failed


    Then i have try a direct connection (since i am not sure what it is)







    +CME ERROR: activation failed

    then as readed in this forum i have try to attach manually :
    +CME ERROR: operation not allowed
    So please help me to understand what append.
    Please note that my AT#CSQ returns 20,0, so i have a correct GPRS cover.


      1. AT+CMGR
        +CME ERROR: operation not supported
        +CME ERROR: operation not supported 
        #SERVINFO: 650,-95,"F SFR","20810",03,070A,00,1,,"II",02,6
        +CME ERROR: operation not supported
        Looks bad !
        1. Yes indeed, maybe you should reload the firmware in that module. Maybe you should try to communicate from another PC, check connections, settings, try another terminal.

          1. Hello,


            I have tried cross test using 3 modules and 2 sim cards, i get the same result.

            (but one of the two sim card allow me to send SMS).


            Any other idea ?

            How can i put back the factory settings ?

            You told about reload the firmware, i have no idea how to do this. My telit module is embedded in a compulab EM-X270 board (http://www.compulab.co.il/x270em/html/x270-em-datasheet.htm) I am not sure i could access to the module firmware if it is need other thant com port to load it.


            Please help me.


          2. Firmware uploading is made on the same port as the one used for AT commands, read "Telit Modules Software User Guide" chapter 6. The same documents describes how to do tests, starting with SIM detection and PIN input, through network checks to more elaborate procedures. Please do thorough checks and let us know.



          3. since i get all the same comportment on all my module, i probably will try to update one firmware.

            Before that can you tell me if there any configuration of the module i could have forget (i a quite new to drive GSM/GPRS modules). Or any bad configuration i could use ?


            Thank you for your reactivity, it is really good to get so fast answers.



          4. It might be bad configuration, but that can be detected only performing the tests, please read the doc and do them, as complete as you can, post results and will proceed further. Might be bad/wrong SIM, bad supply, bad/wrong antenna, etc.

        2. Can i had that if i send a sms





          Test 2011-12-15 04:15:39

          +CMS ERROR: 331


          No network service …

          strange an other sim in another peripheral works…




  2. Please note the following.

    I think you may mistake :

    AT+CMGR instead of AT+CGMR 


    That way the result is 07.02.204

    And my telit module is GC864-QUAD


    (i don’t want to update firmware for now) 

    I have tried another sim card (a sim from a function GRPS 3G usb key) , and sometimes i can get the connection, using the following :


    Initialisation of the modem


    W -> AT#SELINT?<0x0D>

    R <- <0x0D><0x0A>#SELINT: 2<0x0D><0x0A><0x0D><0x0A>OK<0x0D><0x0A>

    W -> AT+CMEE?<0x0D>

    R <- <0x0D><0x0A>+CMEE: 2<0x0D><0x0A><0x0D><0x0A>OK<0x0D><0x0A>

    W -> AT+CGMR<0x0D>

    R <- <0x0D><0x0A>07.02.204<0x0D><0x0A><0x0D><0x0A>OK<0x0D><0x0A>

    W -> AT+CGMM<0x0D>

    R <- <0x0D><0x0A>GC864-QUAD<0x0D><0x0A><0x0D><0x0A>OK<0x0D><0x0A>

    W -> AT+CPIN?<0x0D>

    R <- <0x0D><0x0A>+CPIN: READY<0x0D><0x0A><0x0D><0x0A>OK<0x0D><0x0A>

    W -> AT+CPIN?<0x0D>

    R <- <0x0D><0x0A>+CPIN: READY<0x0D><0x0A><0x0D><0x0A>OK<0x0D><0x0A>

    W -> AT+CPOL?<0x0D>

    R <- <0x0D><0x0A>+CPOL: 1,2,"34020" ……   [BLABLABLA ]

    W -> AT&K0<0x0D>

    R <- <0x0D><0x0A>OK<0x0D><0x0A> 



    then i try to do the following


    W -> AT+CGDCONT=1,"IP", "mmsbouygtel.com"<0x0D>

    R <- <0x0D><0x0A>OK<0x0D><0x0A>


    W -> AT#SCFG=1,1,300,90,600,50<0x0D>

     R <- <0x0D><0x0A>OK<0x0D><0x0A>


    W -> AT+CGQMIN=1,0,0,0,0,0<0x0D>

    R <- <0x0D><0x0A>OK<0x0D><0x0A>


    W -> ATD*99***1#<0x0D>

    R <- <0x0D><0x0A>CONNECT<0x0D><0x0A>


    W-> (pause)  +++ (pause)

    R->  <0x0D><0x0A>OK<0x0D><0x0A>


    W -> AT+CSQ<0x0D>

    R <- <0x0D><0x0A>+CSQ: 12,0<0x0D><0x0A><0x0D><0x0A>OK<0x0D><0x0A>


    W -> AT#SGACT=1,1<0x0D>

    R <- <0x0D><0x0A>#SGAT: Some ip<0x0D><0x0A>


    Since here the Socket commands (open write, close) are working.


    But most of time, i get an activation failed @ AT#SGACT=1,1

    Why ?




    1. Maybe you have problems with the antenna/signal? Check the SIM, registration, signal (AT#MONI, AT#SERVINFO) and GPRS attach just before and after socket activities. A network survey might help finding the coverage situation there.