Script startup execution delay problem

4 thoughts on “Script startup execution delay problem

  1. Hi,


    I’m experiencing some difficulties with the startup delay before script starts executing. I’ve tried to use #STARTMODESCR=1,10 and #STARTMODESCR=0. It takes about 50 seconds before the script starts. I’ve used #STARTMODESCR=1,10 for GM862-GPS and it starts fine.


    I have a script called with content:

    import GPIO

    GPIO.setIOdir(17, 1, 1) 


    As soon as the script starts executing the pin rises. This takes unusually long (50sec) compared to GM862-GPS.


    Any ideas what could cause this? 

    1. Hi Markus,


      What module and firmware?

      Are you using pre-compiled scripts? Please describe the structure of your application files.

      Does the delay appear at each startup or only first time after app files upload?

      Can you provide a small example which shows such a considerable startup difference?

      1. Thanks for quick reply,


        It turns out that my was actually the problem. Got it to drop at 30sec, which is around same as with GM862-GPS.


        My debug class with four lines was too much 🙂 Fixed it by making script, which only imports (which is precompiled to pyo-file using PC).