RTC gets hung when in sleep mode

7 thoughts on “RTC gets hung when in sleep mode

  1. I am working with a GE865 quad module with firmware 10.00.0003. I am running a python script which I use to set an alarm, shut down and then wake back up the specified time. 95% of the time everything works as it should but I am encountering the occasional situation where the RTC seems to get hung. I have a steady 3.7V lipo connected and use the correct 100uf low esr Tantulum capacitor. I do not have VRTC connected to a capacitor since the battery supply is always connected. SIMIN pin is not connected to GND and I use the AT#SIMDET=1 to get the module to detect the SIM. I do have the module get RTC updates from the GSM network.


    An example of what I am seeing is the module runs its sequence and python sets the new alarmwith no trouble. The module shuts down and should wake in 1 hourbut never does. After several hours of not waking I manually wake the module to see what happened and I find that the RTC is several hours behind. For example if I ran the cycle at 8am and set the next alarm for 9 am I would not get any reply and turn it on at 11am. When I turn it on at 11am the clock indicates something like 8:27am. Since the RTC never reached the 9am alarm time it never woke back up. However waking it up manually seems to trigger the RTC to start again and it will eventually reach the alarm time and function normally. 


    In my application the unit will not be available to reset manually so I need to find a way to make sure the RTC is not getting hung. Any suggestions are appreciated!

    1. Please try to put a pause about 2 seconds after at+CCLk=  and after at+CALA=.. commands (MOD.sleep(20)) and check if this modication improves or not the statistic

      1. I am running the at+cclk command several minutes before I set the alarm time with at+cala. The problem I am having is the RTC getting hung while it is asleep. When the unit is awake I have never had any clock issues. The battery is still connected and I confirmed that I do not lose the clock, it just gets hung. Any ideas on why it would get hung? Despite having a steady power source do I need to put a capacitor on VRTC?

        1. Please try to put a pause about 2 seconds after at+CCLk=  and after
          at+CALA=.. commands (MOD.sleep(20)) and check if this modication
          improves or not the statistic.

          If this modification will not improve the statistic we will investigate in another direction. 


          1. I have been running several units hourly for a few days with the suggested modifications and I have been able to replicate the error. Can you please suggest anything else that I should consider in an effort to correct this.





          2. Hi Fred,

            first of all: is the behavior improved significally  in terms of ocurrence or not? Please detail the number of occurrence before and after modifications (number of occurrence/ running period )

          3. I ran three units in hourly cycles for a few days so combined I ran about 250 alarm cycles to test your suggestion. Out of the 250 cycles I was able to see 2 instances of a hung clock. The two instances were on 2 seperate units and the third unit has not recorded any hung clock so far. In previous tests I probably would have had 4-5 instances of hung clock for that same amount of cycles. So it did improve but It is not a reliable method in its current configurtation. If you have some suggestions on wha tI should look at next I would appreciate it.