Using AT#QDNS

3 thoughts on “Using AT#QDNS

  1. Hi,

    I am using a HE910-DG at firmware 12.00.006.

    When trying to resolve a domain name with AT#QDNS I keep getting the error “operation not supported”.

    If I use the domain name with AT#SD it will get resolved while opening the socket.

    Below is the log of how I get to calling AT#QDNS. Do I have to set up anything else before being able to use this command? 

    at+cmee=2

     

    OK

                                                                               

    at+cpin=0000

                                                                                    

    OK

                                                                               

    at+creg?

                                                                                    

    +CREG: 0,2

                                                                                   

    OK

                                                                                

    at+creg?

                                                                       

    +CREG: 0,2

                                                                                   

    OK

                                                                             

    at+creg?

                                                                                   

    +CREG: 0,5

                                                                                   

    OK

                                                                               

    at+cgdcont=1,”IP”,”truphone.com”

                                                                                    

    OK

                                                                               

    at#dns=1,”8.8.8.8″,”8.8.4.4″

                                                                                    

    OK

                                                                               

    at#sgact=1,1

                                                                                    

    #SGACT: 100.65.249.209

                                                                                   

    OK

                                                                                

    at#qdns=”google.com”

     

    +CME ERROR: operation not supported

    Regards,

    Olivier

    1. There is a note at the #QDNS command description, are the conditions fulfilled?

      This command is available only on the first AT instance (see AT#PORTCFG) or on the first virtual port of CMUX and works on the PDP context 1 and on the first ConnId ( see AT#SCFG ).

      1. Ah yes, in my case PORTCFG=0. I switched to the UART interface and it worked.

        Thanks

        Olivier