5 thoughts on “LE910: AT#PORTCFG=? ERROR

  1. We are able to talk to an HE910 module over the USB interface from our proprietary Windows Embedded Compact 7 device. I can query the port configuration, as shown at the top of the screen-shot attachment.


    However, when we try to talk to an LE910 module from the same device, we get no response from the single USB serial port presented by the module (the HE910 present 7 USB serial ports). Furthermore, when I try to query the port configuration over RS232, I get an ‘ERROR’ response, as shown at the bottom of the second-shot attachment. 


    What would cause the command to generate an ‘ERROR’ response? I believe we need to set the port configuration so that we have the full set of 7 USB serial ports available to us but, clearly, we can’t do this when the command generates an ‘ERROR’.

      1. Is there a reason why Microsoft’s standard USBSER driver (a USB CDCACM driver) wouldn’t work with LE910? It works fine with HE910. In other words, does the LE910 require a non-standard CDCACM driver?

  2. Yes, we’re using Windows Embedded Compact 7 and Windows Embedded Compact 2013 (formerly Windows CE).


    I’ve cloned Microsoft’s ‘USBSER’ USB client driver and added the appropriate registry keys for HE910 and LE910 modem modules. We get 7 USB serial ports with the HE910 module with a fully working AT interface on the first serial port (COM1 on our platform).


    So far, we’ve only got the RS232 interface working with the LE910 module. The USB interface is not working correctly. We suspect the modem is not initialising correctly because PWRMON is permanently active, regardless of the state of ON_OFF#. However, we also have pre-production firmware in our LE910 module (17.00.521-B007) and some fairly simple functions, such as the following, return an error:





    Tim Clacy