HE910-G resting issue during \”AT#AGPSSND\”. command

3 thoughts on “HE910-G resting issue during \”AT#AGPSSND\”. command

  1. Dear Sir,

    We are using HE910-G module in asset tracking device. in this, we have to take GNSS location from module built-in GNSS device and send to the server. if GNSS is not available in that case we are requesting triangular based location from the module. 

    previously we were using 12.00.006 module firmware that time everything is working fine but when we updated module firmware 12.00.007. module encountering resets during “AT#AGPSSND”. 

    We have tested this issue with third party evaluation board and Telit EVK-2 and HE910-G Interface board. but the result remains same. 

    Please refer below command sequence.

    AT+CGMM

    HE910

     

    OK

    AT+CGMR

    12.00.006

     

    OK

    AT+CREG?

    +CREG: 0,1

     

     

    OK

    AT#HTTPCFG?

    #HTTPCFG: 0,””,80,0,””,”******”,0,120,1,300,0,0

    #HTTPCFG: 1,””,80,0,””,”******”,0,120,1,300,0,0

    #HTTPCFG: 2,”m2mlocate.telit.com”,9978,0,””,”******”,0,120,1,300,0,0

     

    OK

    AT#SGACT=1,0

    OK

    AT+CGDCONT=1,”IP”,”internet”,”0.0.0.0″,0,0

    OK

    AT#SGACT=1,1

     

    #SGACT: 100.116.255.118

     

    OK

    AT#CACHEDNS=1

    OK

    AT#AGPSSND

     

    OK

     

    #AGPSRING: 200,12.982478,77.600944,0,1266,””,0

     

    #AGPSMPRRING: 1

    AT#SGACT?

    #SGACT: 1,1

    #SGACT: 2,0

     

    OK

     

    Can you tell me what is the issue?

    Thanks,

    Diwakar Singh