GE910 GNSS module Turn-Off , power consumption

3 thoughts on “GE910 GNSS module Turn-Off , power consumption

  1. Hello Telit, 

    After Turning OFF the module and checking power consumption, some times I see that module is still draining some energy.

    What it can be ? PWMON is showing that module is off , but I see that it’s not completely off. 

    p.s. This happen not every time , maybe 1 of 7 tries. Also, I was trying HW reset instead, it’s fine, but this method is not good since it’s not doing detaching from the network. 

    Product: GE910 GNSS

    Software version: 13.00.106

  2. After looking on a problem for several days.

    We found a problem:

    The GPS module of the GE910 GNSS is behaving strange 

    for experiments we set in raw implementing just one command

    while (1)


    gsm_api_set_command(“AT$GPSP=0r”, 2000);



    basically every 5 seconds we are implementing command for swithcing off GPS module 

    during this we are making measurements of the power consumption 

    and what we have that on each “switching off” consumption is jumping up and down 

    in mA we have raw of this values (31, 46, 31, 46 ,31 , 46)  mesaured on the line 12V (also it’s another consumers in the circuit but we don’t need to take it into considiration still application is just working with the gps module ) 

    thats why sometimes we was getting high consumption when we was trying to switch off GSM module.

    And now questions:

     1) Why switching OFF command for GPS is switching it so strange ? 

    2) How to check GPS status, if it’s really OFF ? In AT commands written that AT$GPSP? will not return the real state of the GPS. Ok, but what will return ? 

    3) Was trying different commands for GPS, for example command AT$GPSSTCPUCLK getting error all the time, when gps is powered on and off .. 

    AT$GPSSW? return  $GPSSW: BINIMG_3.

    GPS is set to device type 4

    4 – serial port connected to the GNSS serial port: controlled mode (default for GE910-GNSS). This configuration is for ST TeseoII-based GPS modules support only (SL869)

    Hope for soon reply, did no hear any answer since last friday =)