Windows CE 6.0 HE910 G driver

10 thoughts on “Windows CE 6.0 HE910 G driver

  1. We have Windows CE 6.0 R3 based platform, CPU is TI
    DM3730 which is connected over SMSC USB3320 to Telit HE910 G modem (firmware
    12.00.3). Our problem is, that modem is not responding on any BulkIn Endpoint.
    Modem is correctly enumerated and proper driver is loaded to the system. From
    SW point of view everything looks fine (driver is listening on Interface 1 Endpoint
    82) and sending data to Interface 1, endpoint 2. Problem is that modem doesn’t
    replay on endpoint 82. I tried to connect modem to Windows 7 computer over USB
    and it is responding. Also I tried to connect modem to EVB with the Windows CE
    6.0 R3 with your USB drivers, but behavior is the same, modem is not
    responding. Modem is using standard CDC profile, isn’t it? Is it necessary to
    send some special sequence to the modem to start it? 

     

  2. Hi ,

    is it possible that you  tried another driver at the beginning and then our driver?

    Please collect all the drivers log and the OS logs regarding the host USB host part.

     

     

    1. Hi,

       

      No I wrote just dummy driver for Infineon interface. In first stage I  tested binary driver, after that I got source code from you. Behavior is the same. Log file is attached.

      1.  From the log we can see that only one port is created (COM6): why only one?

        One AT commands is sent but without an answer.

        HE 910 can send the answer if the DTR is high:  how are you sending the AT commands? With a software application?

  3. Yes you are right, I have deactivated (in registry) to load other
    port, just to simplifying log. I am using standard Windows CE function
    CreateFile, ReadFile, WriteFile, CloseHandle  to communicate with modem (COM6:). I am not
    using any other COM function like SetCommState()to modifying COM settings. I am
    going to check DTR state. 

    1. Thank you for your advice.  I setup DTR high and
      driver started responding. My mistake, I kept default settings of the driver,
      without explicit settings of DTR. 

       

  4. Problems with HE910 on our custom platform running Windows Embedded Compact 7.

     

    When we set up a connection using Start–>Settings–>Network and Dial-up Connections –>Make New Connection, and select the main Telit COM port (normally COM6: Telit HSDPA modem), and use the default configuration, then when we open this port in a standard windows test applicationm, the function ReadFile always returns 0 bytes.

    The windows application we use to test basically uses the following snippet of code in a C++ console application:

     

    Normal
    0

    false
    false
    false

    EN-GB
    X-NONE
    X-NONE

    MicrosoftInternetExplorer4

    BOOL b;

    DWORD dw;

    BYTE by[128];

    HANDLE h;

     

    h = CreateFile(_T("COM5:"), GENERIC_READ | GENERIC_WRITE,
    0, NULL, OPEN_EXISTING, 0, NULL);

           // returns a valid HANDLE

     

    b = WriteFile(h, "ATr", 3, &dw, NULL);

           // returns TRUE, dw = 3

     

    b = ReadFile(h, by, sizeof(by), &dw, NULL);

           // returns TRUE, dw = 0 (i.e. no response)

     

    CloseHandle(h);

     

    Note that CreateFile, WriteFile and ReadFile always return a value indicating a successfull call.

     

     

    If the hardware is reset, and the Networking and Dialup step above is missed out, then the port will work fine from the simple windows test application.

     

    Any ideas as to why the port does not work properly after using the Networking and Dialup settings dialog box?