digital audio interfac problem

5 thoughts on “digital audio interfac problem

  1. Hi,

    I have a problem with the digital audio interface, I am using follow hardware: eval board EVK2 with the UC864 interface.

    problem:
    The digital audio port is configured as Master (Slave is not connected) and I can only measure the clock signal.
    (see attachment: UC864_DAI_1-CLK_2-RX_3-TX_4-FS.png)

    question:
    why i can not measure the PCM_SYN & PCM_TX signal?
    is this a fundamental problem or am I doing something wrong?

    The problem is as follows reproducibly:
    > EVK2 with UC864 Interface is used
    > serial connection is used (115200baud, 8data, none parity, 1 stop bit, Hardware Flow Control aktiviert), Software TeraTerm V4.73 (SVN# 4845)
    > connection test
    at
    OK
    at+cpin?
    +CPIN: READY
    OK

    at+csq
    +CSQ: 5,99
    OK

    at+cops=?
    +COPS: (1,”A one”,”one”,”23205″,0),(2,”A one”,”one”,”23205″,2),(1,”E-Plus”,”E-Plus”,”26203″,0),(1,”o2 – DE”,”o2 – DE”,”26207″,0),(3,”3 AT”,”3 AT”,”23210″,2),(3,”A1″,”A1″,”23201″,0),(3,”T-Mobile A”,”T-Mobile”,”23203″,0),(3,”T-Mobile A”,”T-Mobile”,”23203″,2),(3,”A1″,”A1″,”23201″,2),(1,”T-Mobile D”,”T-Mobile”,”26201″,0),(1,”Vodafone D2″,”D2″,”26202″,0),,(0-4),(0-2)
    OK

    atd 0043662439011;
    OK

    ath
    OK

    > Digitale Audio Interface configuration
    at#stm=1
    OK

    at#dvi=1
    OK

    > dvi is configured
    at#dvi?
    #DVI: 1,2,1
    OK

    at#dvicfg?
    #DVICFG: 0,1,0,1,0
    OK

    at#pcmtxg?
    #PCMTXG: 0
    OK

    at#pcmrxg?
    #PCMRXG: 0

    > generate the digital audio signal (see attachment: UC864_DAI_1-CLK_2-RX_3-TX_4-FS.png)
    at#srs=0,5
    OK

    atd 0043662439011564;
    OK

    ath
    OK

     

    Thanks a lot for your help

     

     

    1. Hi Sebastian.

      Thanks for contacting the forum.

      All DVI pins except CLK share teh GPIO function so you need to select alternate function for them so:

       

      AT#GPIO=17,X,2 //  enables SYNC function

      AT#GPIO=18,X,2 // enables RX function

      AT#GPIO=10,x,2  //enables  TX function

       

      So all should be working….

       

  2. Hi Sebastian.

    Thanks for contacting the forum.

    All DVI pins except CLK share teh GPIO function so you need to select alternate function for them so:

     

    AT#GPIO=17,X,2 //  enables SYNC function

    AT#GPIO=18,X,2 // enables RX function

    AT#GPIO=10,x,2  //enables  TX function

     

    So all should be working….

     

     

    Hi Luca

     Two questions on the GE864GPS hardware manual says that the ball K7 (DVI RX), ball D7 (DVI CLK) and H5 ball (DVI WAO) are I / O but since I can read if I want to use as GPIO and as DVI
    AT # GPIO =?, 0 What is are the addresses of these three I / O? or is an error in the manual

     

    Best Regards

     

    Giovanny

    1. Hi Giovanny,

       

      are your question related to Sabastiamn one? since this post was related to UC864 product and you are talking about GE864 GPS.

      Please leave this post closed and open a new one so we can keep clear the forum