AT+COPS=? CME ERROR: 100

4 thoughts on “AT+COPS=? CME ERROR: 100

  1. Dear Sir or Madam

     

    I can not get the all operators after PDP context is set up. I running the test on a Starter Kit S3 with UC864 connected to a Linux over USB.

    Firmware SW-Version:

    08.01.107

     

    AT-Log

    ————

    ATE0

    AT+CMEE=1

    AT+CNMI=0,0,0,0

    AT+CPIN?

    AT+CPIN=

    AT+COPS=?

    shows the operators

     

    setup PDP context with pppd

    – AT+CGDCONT=1,"IP","","0.0.0.0",0,0

    – ATD*99***1#

     

    AT+CGACT?

    +CGACT: 1,1

    OK

    AT+COPS=?

    +CME ERROR: 100

     

    CME ERROR 100 is defined as UNKNOWN

     

    Do you have an idea, how this could happen?

     

    Sincerely

     

    Christoph Eck

    1. Could it be a network issue?

       

      I’m not able to see any difference using the same sw. version and an italian SIM card.

       

       at+gmr
      08.01.107

      OK
      AT+CREG?
      +CREG: 0,1

      OK
      AT+CGDCONT=1,"IP","web.omnitel.it"
      OK
      at+cops=?
      +COPS: (2,"vodafone IT","OMNITEL","22210",0),(1,"SI.MOBIL","SI.MOBIL","29340",0)
      ,(3,"3 ITA","3 ITA","22299",2),(3,"I WIND","WIND","22288",0),(3,"I TIM","TIM","2
      2201",0),(3,"I TIM","TIM","22201",2),,(0-4),(0-2)

      OK
      at#sgact=1,1
      #SGACT: 109.113.241.190

      OK
      at+cops=?
      +COPS: (2,"vodafone IT","OMNITEL","22210",0),(1,"SI.MOBIL","SI.MOBIL","29340",0)
      ,(3,"I WIND","WIND","22288",0),(3,"3 ITA","3 ITA","22299",2),(3,"I TIM","TIM","2
      2201",2),(3,"I TIM","TIM","22201",0),,(0-4),(0-2)

      OK

      Did you try what is the result with another  net operator?

    2. We use Telit HE910. Whenever there is internet data transaction, for example, "ping 8.8.8.8", same time AT+COPS=? doesn’t work.

      Other AT Commands works though.

      We heard from local  Telit (India Support) team that this is a known behaviour and we are now doing retries to resolve the problem.

      But, if you have constant internet data transaction, I don’t think there is a way of getting response for AT+COPS=? at all. Telit Technical Team can guide you though.

      1. In case you have active data connection AT+COPS=? don’t work since the module cannot scan for available GSM/UMTS networks keeping a data transfer.

         

        If PDP context is active but without data trasfer then network search should be possible.