SIM Problem – CREG 1,3

8 thoughts on “SIM Problem – CREG 1,3

  1. Module:GM862-GPS
    Firmware:07.03.401
     
    SIM card from Telcel(Mexico) operator

    CPIN returns ERROR (SIM Failure or SIM Busy)
    then CREG becomes 1,3, so I have to CFUN=4 …. CFUN =1 and then CPIN then is READY

    CREG then reports CREG 1,2 and then REG 1,1  ….. (after 4-5 minutes) it becomes
    CREG 1,3

     then I have to CFUN=4 and CFUN=1 to get CPIN READY but CPIN ERROR and CREG 1,3 are back after a few minutes.
     
    Any clue about what is happening?

    Below the commands and timestamp, also I include at bottom STIA and SATR commands
     
     1:17:49:54:
    +CREG: 3
    1:17:53:39: AT+CPIN?
    AT+CPIN?

    ERROR
    1:17:53:45: AT+CFUN=4
    AT+CFUN=4

    OK
    1:17:53:47: AT+CFUN=1
    AT+CFUN=1

    OK
    1:17:53:59:
    +CREG: 2
    1:17:54:05:
    +CREG: 1
    1:17:55:31:
    +CREG: 3

    1:18:13:59: AT+CFUN=4
    AT+CFUN=4

    OK
    1:18:14:03: AT+CFUN=1
    AT+CFUN=1

    OK
    1:18:14:06: AT+CREG?
    AT+CREG?

    +CREG: 1,0

    OK
    1:18:14:11: AT+CPIN?
    AT+CPIN?

    +CPIN: READY

    OK
    1:18:15:26: AT#CPIN?
    AT#CPIN?

    ERROR
    1:18:15:39: AT+CFUN=4
    AT+CFUN=4

    OK
    1:18:15:41:
    +CREG: 0
    1:18:15:45: AT+CFUN=1
    AT+CFUN=1

    OK
    1:18:15:55:
    +CREG: 2
    1:18:15:58:
    +CREG: 1
    1:18:16:05:
    +CREG: 3

    ———————————————————————–
    Other questions regarding this Bad SIM:

    After several CFUN=4, CFUN=1, #reboot when I got CPIN=ERROR the Telit reboots and sometimes returns a "#STN: 37" string.  Do you know why? I don

     

    >>>

    ———————————————————————–

    Other questions regarding this Bad SIM:

     

    After
    several CFUN=4, CFUN=1, #reboot when I got CPIN=ERROR the Telit reboots
    and sometimes returns a "#STN: 37" string.  Do you know why? I don’t
    use STIA

     

    Also I tried the STIA command in BAD SIM and it returns (With CMEE=2)

     1:18:30:26: AT#STIA?
    AT#STIA? +CME ERROR: SIM failure

     

    In a "normal" SIM it returns:

     1:20:43:14: AT#STIA? <– NORMAL SIM#STIA: 1,2,10,7fffffff7f00005f06000000000000000000

     ————————————————————————

     I tried SIMATR in BAD SIM

    AT#SIMATR

    #SIMATR: FE3B3B9600A74C900000046855559000

     

     In a "normal" SIM it returns:

     1:20:25:59: AT#SIMATR

    #SIMATR: 3BFF950000C00A1F438031E073F62113574A430E1831303063

    ——————————————————————————-

     

  2. Please do an AT+CMEE=2 command.

     

    Is this the only one SIM card with problems or all that you have behave the same? What hardware are you using, board/device?

     

    One thing to check and try: fix radio band with:

    AT#BND=3

    AT#AUTOBND=0

    Reboot and check.

     

    1. I had BND=3 but not AUTOBND=0, I set the commands each time CPIN is SIM Failure and Reboot, when it reboot CPIN is Ready and CREG 1 but after some minutes I get CREG 3

       

      2:17:13:18:
      +CREG: 1    <———— Registered
      2:17:17:47:
      +CREG: 3    <———— Registration denied after 3-4 minutes
      2:17:25:57: AT+CPIN? <— SIM Failure
      +CME ERROR: SIM failure
      2:17:26:04: AT#BND?
      #BND: 3
      2:17:26:12: AT#AUTOBND?
      #AUTOBND: 0
      2:17:26:17: AT#BND=3 <— Set BND=3
      AT#BND=3
      2:17:26:21: AT#AUTOBND=0
      AT#AUTOBND=0
      OK
      2:17:26:23: AT#REBOOT <– Reboot
      OK
      2:17:26:43:
      +CREG: 2     <———– Searching
      2:17:26:46:
      +CREG: 1     <———– Registered
      2:17:27:11: AT+CPIN?
      +CPIN: READY <———– SIM Working!
      2:17:27:20: AT+CPIN?
      +CPIN: READY
      2:17:31:00:
      +CREG: 3     <———– Registration denied again
      2:17:31:30: AT+CPIN?
      +CME ERROR: SIM failure<- SIM Failure
      2:17:31:46: AT#BND=3 <— Set BND=3
      OK
      2:17:31:49: AT#AUTOBND=0
      OK
      2:17:38:16: AT+CPIN?
      +CME ERROR: SIM failure
      2:17:38:19: AT#REBOOT <– Reboot
      OK
      2:17:38:28: AT+CPIN?  <– Sim Failure
      +CME ERROR: SIM failure
      2:17:38:38:
      +CREG: 2     <———– Searching
      2:17:38:41:
      +CREG: 1     <———– Registered
      2:17:38:47: AT+CPIN?
      AT+CPIN?
      +CPIN: READY <———– SIM Working! Without CFUN 4 and CFUN 1
      2:17:50:12:
      +CREG: 3     <———– Registration denied again
      2:17:50:42: AT+CPIN?
      +CME ERROR: SIM failure<- SIM Failure
      2:17:50:53: AT#REBOOT
      AT#REBOOT
      2:17:51:12: AT+CREG?
      +CREG: 1,2
      +CREG: 2
      2:17:51:14:
      +CREG: 1
      2:17:53:11: AT+CPIN?
      +CPIN: READY <———– SIM Working! Without CFUN 4 and CFUN 1
      2:18:30:22:
      +CREG: 2
      2:18:30:25:
      +CREG: 1     <———– Registered
      2:18:41:54:
      +CREG: 3     <———– Registration denied again After 11 minutes
      2:18:43:18: AT+CPIN?
      +CME ERROR: SIM failure<- SIM Failure

      We designed our device for an asset tracking application, we have 80
      devices working well but we got 4 that don’t communicate with server
      anymore, when we open our device we found that the 4 devices had SIM
      Failure, what we did was replacing the SIM
      Cards and then the device continued working well so I don’t think it could
      be our device, I’m think, the problem maybe is in the SIM Cards. 

       

      I have those SIM Cards and I’m testing them I found that with CFUN=4 and CFUN=1 and then REBOOT or even without reboot we got the CPIN Ready but I need to investigate more. The #STN: 37 is a mistery for me, and sometimes the CPIN return SIM Busy instead SIM Failure. I hope it helps.

       

      Regards,

       

      Luis

       

       

       

       

       

       

      1. All these symptoms lead to the idea that the SIMs are indeed defective in some way, or the is a contact problem in the holder. Are these 4 SIMs different in any respect of the other you have? Do they work in a cell phone?

         

          1. Luis, our technical support team asks you to set AT#REGMODE=1 and repeat the test, they are suspecting that is not the real status.

          2. It turns out that in REGMODE=0 CPIN returns SIM PIN and PUK required but in REGMODE=1 CPIN is SIM Failure.

            I think that may be the CFUN 4 and CFUN 1 and REBOOT procedure to get CPIN Ready was like a turn around for this problem and we got CPIN Ready for some time and then SIM Failure.

            What can cause that a SIM asks for PIN and the PUK?

             

            SIM REPORTING SIM FAILURE in REGMODE=1 y use REGMODE=0 then reboot and this happened.

             

            00: AT+CPIN?
            AT+CPIN?

            +CPIN: SIM PIN

            OK
            10: AT#REGMODE?
            AT#REGMODE?

            #REGMODE: 0

            OK
            31: AT+CREG?
            AT+CREG?

            +CREG: 1,3

            OK
            51: AT+CPIN=1111
            AT+CPIN=1111

            +CME ERROR: SIM PUK required
            01:20: AT+CPIN=97171579,2222
            AT+CPIN=97171579,2222

            +CME ERROR: unknown <———— Is this correct?
            01:44:
            +CREG: 2
            02:11: AT#REBOOT
            AT#REBOOT

            OK

            04:03: AT+CPIN?
            AT+CPIN?

            +CPIN: READY <——— we got SIM Ready

            OK
            04:20: AT+CGMR
            AT+CGMR

            07.03.400

            OK
            04:32: AT+CREG?
            AT+CREG?

            +CREG: 1,1

            OK
            04:35: AT+CREG=1
            AT+CREG=1

            OK
            05:16: AT
            AT
            05:13: AT#REGMODE=1 <— REGMODE turn to 1

            OK
            05:32: AT+CPIN?
            AT+CPIN?

            +CPIN: READY

            OK
            05:58:
            +CREG: 0             <————CREG 0

            06:11: AT+CPIN?
            AT+CPIN?

            +CME ERROR: SIM failure <———–
            06:33: AT+CPIN?
            AT+CPIN?

            +CME ERROR: SIM failure
            06:38: AT#REGMODE?
            AT#REGMODE?

            #REGMODE: 1

            OK
            07:20: AT+CPIN?
            AT+CPIN?

            +CME ERROR: SIM failure
            07:29: AT#REBOOT
            AT#REBOOT

            OK
            07:33: AT
            AT

            07:47: AT+CPIN?
            AT+CPIN?

            +CPIN: READY

            OK
            07:54:
            +CREG: 2
            07:56:
            +CREG: 1

             

            Did a Hard Reset and then it stays in CREG 1 and CPIN Ready now.

            What caused that the SIM asked for PIN and the PUK?

            Any Ideas?

          3. Just a status update on this: our FAE is working to test these SIM cards with Luis, will post news here.