Registration denied

6 thoughts on “Registration denied

  1. Hi,

     

    We have been using GM862-Quad modems in our application. Application development is done in Slovakia and sales in Sweden. In Slovakia configuration and data transmittion (via GPRS) works correctly, however in Sweden modem is unable to register to network – always ending with  +CREG: 0,3 registration denied. 

    This problem occured with latest firmware for telit modems (07.02.606). However, we also have some modems with older firmware 07.02.604 and they seems to be working just fine, but when we tried to downgrade the firmware in those newer modems the problem remained the same – registration denied.

     

    This is all the configuration done prior the registration denied response (strip down some white chars):

     

    Sent: AT
    Received: AT OK

    Sent: AT+IPR=38400
    Received: AT+IPR=38400 OK

    Sent: ATE=0
    Received: ATE=0 OK

    Sent: AT#SELINT=2
    Received: OK

    Sent: AT+GMR
    Received:
    07.02.606 OK

    Sent: AT+CMEE=2
    Received: OK

    Sent: ATS12=50
    Received: OK

    Sent: AT#GPIO=5,0,2
    Received: OK

    Sent: AT#GPIO=6,0,2
    Received: OK

    Sent: AT#GPIO=7,0,2
    Received: OK

    Sent: AT#SRP=3
    Received: OK

    Sent: AT#CAP=2
    Received: OK

    Sent: AT+CPIN?
    Received: +CPIN: READY OK

    Sent: AT+CREG?                          –  this is repeated all the time
    Received: +CREG: 0,3

     

    In Sweeden they have been using SIM card from Telia. Do you have any idea what might be wrong, or what can we try to make it work?

     

    Thanks

     

    Roman Bris

  2. Hi,

     

    I have tried the AT#REGMODE=1. I have entered this command just prior the  AT+CREG? call (hope thats ok) but the still the problems there.. +CREG: 0,3

    One more thing occured to me.. When I do this testing home in Slovakia the first response is usually +CREG: 0,2 or something similar meaning that the device is trying to connect to some network, but in Sweden it directly goes to the registration denied.

    1. Hi Roman,

       

      we have several customers in Sweden using Telit network and we are not aware about any particular issue with Telit SIM cards with 7.02.606 or previous sw. versions.

      Moreover the fact that you downgrade the modules from 7.02.606 to 7.02.604 without any benefit, it seems to indicate that this could be an hw problem….antenna connection or something related to the RF path.

       

      Could you please copy here the response of AT#SERVINFO and AT#CSURV  ?

      1. Sent: AT#SERVINFO
        Received: 

        OK

        ERVINFO: 22,-48,”TELIA S”,”24001″,30,1F50,00,1,,”I”,01,640A000A

         

        AT#CSURV 

         ERROR

         

        this is what I get when I run this on device in sweden, on the device running in slovakia I get quite a long output from the AT#CSURV (using the same firmware on my device)

         

        However I found out that if I use AT#SELINT=0 the modem is able to register to network and work properly, but I dont understand why.

         

        I dont think there is something wrong with the antenna, I have tried some different modem (one of those that we know that works) and I can see that there is great signal in the area. Also we have tried this with more than one modem (so its not very probable that the antenna was connected wrong only on those with latest firmware)

        1. -48dBm is a very strong signal. Actually it is the maximum value reported on 3GPP specs.

           

          The real signal received could be also stronger -40dBm or more but #SERVINFO can only show -48 as max. value.

          Would it be possible for you to repeat the test with the same non working configuration, inserting an attenuator between the antenna and the module or putting the antenna in a different place where the signal is not so strong?

           

          When you set AT#SELINT=0 and the module is able to register, does the #SERVINFO returns the same info as above?

          #SERVINFO: 22,-48,"TELIA S","24001",30,1F50,00,1,,"I",01,640A000A