Upgrading GE-865 Quad Firmware Error

3 thoughts on “Upgrading GE-865 Quad Firmware Error

  1. Hello there,

    we have a GE-865 Quad built into a Linux System, and I’m trying to update using the xfp tool under Windows 7. I’ve created a Virtual Com Port (with Virtual Serial Port Emulator) and connect it via a tcp listener to the Linux device file on the other machine. I can write AT-Commands and read the answers from it with this way.

    As soon as I’m starting the firmware update process, I can see a stream of ‘U’ being sent to the modem, with state linking. Then I power on the modem, and a couple of binary bytes are received from the modem (4 bytes, 0x00,0x92,0x00,0x00).

    The Firmware updater then sends a bunch of binary data (411 bytes) and then stops with following error:

    Error rx (0x00000050 – 0x000001EB), Code: 0 (code: -9)

    I’m using XFP Version, baudrate¬†set to 115200 (but tried others too).
    The firmware to be installed is 10.01.001
    The firmware already installed is 10.00.003.

    Is there anything I can do about this error?

    Best Regards

    1. The uploader protocol is sensible to timings, this might be a problem. In case you wnat to try some tricks, the protocol specifications are available under NDA, contact Telit to obtain it.

      1. Hi,

        the NDA stuff is already in progress. I just thought the error message could be interpreted and there might be a simple solution.