#SMSATRUN

7 thoughts on “#SMSATRUN

  1. Good morning,

    I’m working with GC864-QUAD V2

    I would use the SMS Run AT Service to change some setting work…

    but it does not work!

     

    For example, I tried to delete a SMS by sending this SMS with my phone:

    HAT+CMGD=2

     

    ..the module responds with unsolicited:

     

    #SMSATRUN: AT+CMGD=2

     

    but retrying the command

     

    AT+CMGL="ALL"

     

    the message is still present

     

     What am I doing wrong? help me please.

     

    Thank you !

    1. Just tested and verified, all well. Did you get the OK back? The message on index 2 really exist? Can you delete it directly on module?

       

      1.  

        Hi, thanks for reply

         

        …answer your questions

         

         Did you get the OK back?  ??? WHERE ???

        If I write "HAT…" I do not expect answers,

        if I write "AT…" in the SMS I receive "ERROR"

         

         The message
        on index 2 really exist? YES

        Can you delete it directly on module? YES

         

         

        ???

         

         I’m waiting for new…

          1.  

            I’ve tried and nothing changes.

             

            I discovered that it doesn’t works if I send the sms from my phone, but if I send it from the Telit module is ok !!

             

            Why ?

          2. Did you set AT+CMEE=2 and still only ERROR message back?

             

            Are other commands accepted?

             

            Did you set the white list for remote AT run?

          3.  

             

            …answer your questions

             

            Did you set AT+CMEE=2 and still only ERROR message back? YES
            Are other commands accepted? NO
            Did you set the white list for remote AT run?  YES

             

            However, as already mentioned, I discovered that it doesn’t work with SMS sent from some mobile phone !!

             

            but I do not know why….