Power Consumption on GE865

13 thoughts on “Power Consumption on GE865

  1. Hi,


    On page 29 of "GE865-QUAD_Hardware_User_Guide_r12" it’s said that power consumption on GE865 QUAD in modes CFUN=0 and CFUN=5 are:


    3,9mA  Paging Multiframe 2
    2,5mA  Paging Multiframe 3
    2,4mA  Paging Multiframe 4
    1,5mA  Paging Multiframe 9


    But i’m not able to get these values on my module. When i set it to CFUN=0 it alternates between 5~7 mA  and sometimes a 16~20mA peak. MCU is in sleep mode (0.17 mA) and there’s nothing else on. Is there anything else that should be set to achieve the lower current comsuption ? How can i check what’s the paging multiframe mode of my gsm operator ?


    Can i force it to operate in Paging Multiframe 9 ?



  2. Nevertheless please do the current measurement on VBATT and VBATT_PA lines only, if you have access to only these.


    Ah, and do you have the possibility to upgrade to the latest firmware and repeat measurements?

    1. Ok, here’s what i’ve just tested:


      Initiated the GE865 and set CFUN=0, current ~5.20 mA


      then with GE865 on in CFUN=0, i cut the track that powers 3.3V LDO, (had to cut because the track that feeds VBATT, VBATT_PA and 3.3V LDO is the same). So i cut it between GE865_VBATT and LDO.


      Now only GE865 is powered by battery and module is still in CFUN=0.


      But instead of lower consumption, it increased to ~5.30 mA i don’t know why.


       I’ll try to update to firmware 10.00.003 and test it again.

  3. Hi Cosmin,


    I’ve updated my 3 modules from 10.00.002 to 10.00.003.


    All 3 were consuming minimum 5~8 mA with firmware 002.


    Now, all 3 are consuming 0.91~1.5 mA with firmware 003.


    So, power saving is NOT working properly in firmware 002.


    You really should put this info on the user guide, so nobody else wastes time like i did…


    Before trying to ask here, i sent a message to the Brazilian technical support of Telit, and they told me my circuit was consuming the extra power and didn’t even mentioned this new firmware 003. That’s absurd…


    Thank’s for your help

    1. Hi Bruno,


      I can’t remember (and don’t have older docs at hand) how consumption values evolved over the time and firmware revisions, however if you look in Hardware User Guide at 1.7 Document History you can see these numbers were updated in many revisions, following firmware versions improvements I suppose.


      If a problem arise is always better to upgrade to the latest firmware.  BTW 10.00.x04 is coming, check announcements section from time to time.


        1. Hi Bruno, there is no suggestion that +CALA influences the power consumption, indeed 10.00.x04 has improved the numbers. This version is not released yet, but I think you can obtain it from your direct Telit contact, also check your email from time to time.