POST data to server ..

11 thoughts on “POST data to server ..

  1. Hi.

    I make some project , notifycation for Android .

    if in my brouwser use this :

    then I received notifycation to my mobile.

    now I want to do it with my GL-865 DUAL , AT+GMR is 10.00.154 (litle old version)

    I open GPRS with AT#GPRS=1 and receive IP address .

    Then I can open socket with AT#SD=1,0,80,””,0,0,1 for command mode.

    And with AT#SSENDEXT I need send data to server .. but I don’t know how to manage it .. 

    or what command I need to use …


    1. It is easier to use the HTTP Client AT command set, #HTTPCFG, #HTTPQRY, #HTTPRCV; you’ll have to use the SSL handling stuff  being a https connection. See 3.4.5 HTTP GET over SSL/TSL Example chapter in Telit IP User Guide doc.

      1. Hi .

        EHm .. my module have very old fimrware then not support HTTPS … OK.. but I solve this problem with sending emial .. and receive notifycation too..

        but have little problem..

        I use this : AT#SEMAIL=””,”Test Telit Email”

        .. and I received notifycation ..but Subject is:             =?UTF-8?Q?Test Telit Email?=

        then what coding is used ??

        for notifycation API is : 


        It is important to note that all email messages must be ASCII or UTF-8 encoded, or any other “compatible” encoding. If you are having problems with email notifications not been delivered, please make sure you are not using a “non-western” encoding, like ISO-2022-JP for example.

        then what is wrong ??

        Where I can download latest firware for my module ??? 


          1. Hi. 

            EHm problem is in your firmware .. I try send email to my PC  – standard email client and look to source code of email ..and see this :

            Subject: =?UTF-8?Q?Test Telit Email?=

            This mean so module send this as subject .. you can check it ???
            my firmware is very old and don't have new version .. and I must register to download zone .. is not possible send me ftp link to direct downnoad ??
            it'more easy and faster .. thanks ..


          2. Hi.

            I do test .. 

            Step by Step .. 

            if in subject use char (space) x20 hex , 32dec  -> “Ranne ” then show this : =?UTF-8??Ranne ?=

            if use only “Ranne” then all is OK.. your fimrware must do something .. 

            for this time I solve this problem .. not use space use _ but try find what is problem .. pls ..

            PS: send link for latest firmware .. 


          3. PS: … very interesting .. I use _ insted space and if receive email then in subject is not char _ but space .. hehe .. interesting .. 

            what is it ??

            PS: sorry .. I have firmware .. but right now I see I don’t have software to upload firmware to module .. sorry.. send link for this too..

            PSS: sending email is really fast .. very fast .. supper .. thanks ..

            best regards.

          4. Thanks .. tomorrow try reflash module .. and will see what happend .. but my solution using _ instead space is working .. 

            now can finish my project .. thanks ..

            best regards

          5. Hi .

            I upload latest firmware to my GL865-DUAL and try send email to mu notify server .. 

            still same problem with space character . I not use “space” use “_” character .. all working ..

            PS: now only to know how to send data to google spreadsheet from module..


            PSS: hehe in documentation for AT#ENAME is : Note: do not use the SPACE character. In place of it, use UNDERSCORE
            (“_”), but only if <charset> is 0.

            then this is not bug .. this is OK .. sorry..