GPRS activation failed

6 thoughts on “GPRS activation failed

  1. Hi.

    I test my code and have problem with activation GPRS.

    My code if receive SMS with special command then try connect to GPRS.

    After this send to GMS module :

     

    AT#GPRS?
    #GPRS: 0
    OK

    AT#GPRS=1
    +CME ERROR: activation failed

     

    On first control if is actived or no . if no then try it.

    but failed. 

    are there any command that I can find the cause?? I reset the connection (AT + CGDCONT , AT # USERID,  AT # PASSW ) and the connection still fails 

    some time before everything worked

    what commadn I can test for find problem???

     

    regards 

      1. I try it again and again , bad don’t work.

        I thinks so if GSM module receive SMS , send SMS or is any call ( in or out) then GPRS is disabled. and I must wait some time .
        I try it.

        Is my theory  true???

         

        regards 

        1. in AT command reference guide is write (page 323) 
          During a call, a SMS sending/receiving or a location update the value of <GPRS>, <PB-ARFCN>, <NOM>, <RAC> and <PAT> parameters don’t make sense.

           

          it’s mean so must wait some time or control <GPRS> , if <GPRS> is 1 then I can ake GPRS connection and use any socket.

           

          1. Hi, i don’t think the received SMS is disturbing your GPRS connection, as you said, the SMS is already received and analysed by your software.

            Instead of using these old at commands (at#gprs, at#userid, at#passwd), try to connect as explained in "Telit_IP_Easy_User__Guide_r10.pdf"

            AT+CGDCONT = 1,"IP","apn.address.com","0.0.0.0",0,0<cr>      (GPRS context setting)

            AT#SCFG=1,1,300,90,600,50<cr>
            OK

            AT#SGACT=1,1,“user“,“password“<cr>
            #SGACT: 193.199.234.255
            OK

            If it doesn’t work, check if GPRS is attached with command AT+CGATT? If it’s not attached , attach it manually with AT+CGATT=1

             

            if GPRS is attached and APN parameters are correct it must connect…

          2. yes but if gsm module receive sms or is any call then GPRS is detach.

            and I can’t attach  GPRS while <GPRS> in #SERVINFO is 0, if change to 1 then can attach.

            of course if GPRS is 1 and receive SMS or is any call then …

            I must make some test , for this ..