GE865 sometimes not reporting BER during sensitivity testing

8 thoughts on “GE865 sometimes not reporting BER during sensitivity testing

  1. I
    have a problem when testing Rx sensitivity on GE865 using the CMU200 call
    tester. I am controlling the CMU200 using the CMUgo to do full sensitivity
    sweep across GSM 900 band. sometimes during the test the GE856 module goes into
    a strange mode where it is allocated(i.e in a call) I can read all Tx
    parameters such as power phase noise freq error etc. however, the CMU200 cannot
    manage to read BER. even if I manually pause the test and wind up the received
    power. I still cannot read BER and I get a message on the CMU saying ”Unable
    to close the loop, check SIM card”. I tried to disconnect the call and re-connect and still not able to get BER reading. The only solution is to power cycle the module.

    P.S. I tried the same SIM card with the same
    CMU and CMUgo on a mobile phone and it never shows this error.

    Any Thoughts?

    Many Thanks in Advance

    Hassan Kayali

    RF Design Engineer 

     

    1. Hi Hassan,

       

      please try the following procedure:

       

      1)      Check Module is registered on CMU200 with “at+creg?”

      2)      Perform a voice call ATD1234;

      3)      As soon as the the call is active, press “connect Control” and then “receiver Quality” on the bottom

      4)      Press on “BER” on the left side and the press “stop Condition” on the bottom side. Select “NONE”

      5)      Press on “Application” (on the left side, just below BER button) and then press “BER” on the bottom side to start BER measurement

      6)      Press on “BER average” to start BER measurement

      7)      To change Power Level, Press on “MS Signal” on the left, and then press on PCL on the bottom. Select new PCL

      1. Hi Andrea,

        Thanks for your quick response.

        I have
        already tried all of the procedures you have mentioned. Basically during the
        full sweep sensitivity test, the GE856 module on some random channels just stop
        reporting BER. so the module is registered on CMU200 with at+creg command and I
        can perform a voice call and I can read as I said all Tx power parameters from
        the CMU200. However, when I go to ”receiver quality” menu, both BER and BER average
        do not report any value (with stop condition = none). every time I force BER
        measurement to start manually, I always get a message on the CMU200 screen,
        ”Unable to close the loop, check SIM card”. Only solution as I said is to reboot the device.

        This
        problem happens randomly I cannot repeat it on the same channels!!

        Is
        it possible to trace the module when it goes into this mode and send you the
        trace log?

        Thanks for your help and waiting for your comment.

          1. Just to let you know, I have tried the test on GT-864-PY evaluation kit and it give the same problem. ”close loop command rejected”!! so the module only reports TX but it does not close the loop so no Rx quality test

          2. Just to let you know, I have tried the test on GT-864-PY evaluation kit and it give the same problem. ”close loop command rejected”!! so the module only reports TX but it does not close the loop so no Rx quality test