CME ERROR: activation failed

14 thoughts on “CME ERROR: activation failed

  1. Hi,

     

    we are using the GE865-Quad on a handheld device.

     

    A customer of us uses the device with a german vodafone SIM in Germany and Norway.

    The device has to download a specific file once a day.

     

    During the last weeks the customer did some tests in Germany without any problem.

    But last week the customer tests it in Norway where downloading the file failed.

     

    Since then it was not possible to download that file again. Even when the device was returned to Germany.

     

    When the download fails the device starts a retry after 9 hours. But also no success.

     

    The error is always the same. The GE865 returns +CME ERROR: activation failed. Before the host processor sent AT#SGACT=1,1.

     

    The PDP context has been defined with AT#CGDCONT=1,”IP”,”m2m.vodafone.de”

     

    What may be the reson for this failiure? Under which circumstances could a GE865 return this kind of error?

     

    We have implemented an error logging function where every unexpected response of the GE865 is stored. If necessary I can post the log. 

     

    Unfortunately we can not reproduce this behviour in the lab.

     

    Best regards,

    Alexander Bülow

     

    1. Maybe there are transient/temporary problems with networks interconnections, or limited cells resources in Norway, GPRS not being available.

      If you can test with AT#CEER and AT#CEERNET maybe something will show. 

      1. Is this something that only happens when there are problems with the network connection?

         

        Since the device has been in Norway the problem also occurs here in Germany.

         

        Can this also be caused by a poor battery?

        1. I don’t think low battery can cause this, will rather reboot.

          Did you change the QOS (AT+CGQMIN, AT+CGQREQ)?

          Set AT+CMEEMODE=1; investigate as said with AT#CEER and AT#CEERNET.

          1. The QOS have been modified using AT+CGQREQ.

             

            I don’t know which values are used by the customer. If this can be the cause I will check that.

             

            I implemented CEER and CEERNET and provided a firmware update to the customer. Once the error occurs again we will see the result.

          2. Hi,

             

            here are the QOS values used by the customer.

             

            Precedence 3
            Delay 4
            Reliability 3
            Peek 0
            Mean 0

             

             

            Is it possible these values are not ok?

          3. Hi,

             

            now I have got results from the customer.

             

            Here it is:

             17.8.12 9:59:5 : +CME ERROR: activation failed
            17.8.12 9:59:5 : +CGATT 0
            17.8.12 9:59:5 : #CEER 237
            17.8.12 9:59:5 : #CEERNET 0

             

            This is an excerpt from the device error log. Every unexpected response is stored in an internal EEPROM.

             

            What is SM refuse?

          4. Hi,

             

            sounds as if we are on the right way to figure out what is going wrong.

             

            Are you going to ask your colleagues?

             

            Kind regards,

            Alexander Buelow

          5. I don’t think QoS is the issue, at least if they have modified only the +CGQREQ. These are requested QoS.

            Normally the PDP contaxt activation can fail when minimum QoS are too high (+CGQMIN).

             

            Anyway I see on the log that:

            17.8.12 9:59:5 : +CGATT 0

             

            there’s no GPRS attach.

            Can you confirm that AT#AUTOATT=1 is still set as default parameter?

             

            Did you try to test another SIM card?

          6. Hi Andrea,

             

            we did not change the AT#AUTOATT parameter. I just verified on my device it has the correct value.

             

            Until now the customer did not test another sim card. I will ask him to do so.

             

            Is there a way to figure out the reason for a SM refuse?

             

            kind regards

            Alexander Buelow

          7. Hi Alexander,

             

            are you sure you don’t need and username and password for this M2M apn?

             

            Searching in internet I’ve found: 

             

            apn: m2m.vodafone.de

            user: D2

            passw: D2

  2. Hi

     

    I had exactly the same problem in Norway, with Estonian EMT Internet SIM card. In my case it didn’t work in a mobile phone either.

     

    After a very long troubleshooting it came out to be something wong on the operator size. Enable/disable roaming service must have refreshed some systems because it started working after that and haven’t failed since then.

     

    Regards

    Lauri