SMS and GSM library

9 thoughts on “SMS and GSM library

  1.  

    Hi,

     

    I am  using GE863 PRO-3 module and I am trying to send sms using telit GSM library. I have copied the
    C0.00.08 version as shown in the
    "Telit_GE863-PRO3_Linux_GSM_Library_User_Guide_r2.pdf" document. Using
    the the GSM_ConfigSMS() and GSM_SendSMS() functions as shown in the
    above PDF document I got an GSM_TIMEOUT_ERROR. Next I tried to run
    GSM_Configure() function to define a new timeout factor but Eclipse
    seems to ignore this function, although it produces no errors during
    compilation, and the GSM module runs succesfully all the other GSM functions
    except GSM_Configure(). Have you got any suggestions or ideas on how to
    get over this problem?

    Thanks in advance,
    Sotiris

    1. How do you call the function and what return value are you getting?

      What version is the GSM library you have?

      1. The functions GSM_ConfigSMS() and GSM_SendSMS() give the following return value: GSM_TIMEOUT_ERROR.

        I am using the C0.00.08 version of the library.

          1.  To call GSM_Configure function I used the following example: 

             

            GSM_ErrorCode_t result;
            result = GSM_Configure(GSM_CONF_TIMEOUT_FACTOR, (void *) 110);

             

             

            GSM_Configure doesn’t run at all. It is totally ignored. It is like I have commented out (//) this function. So I don’t get any return value.

          2. I call this fuction using the following example:

             

            GSM_ErrorCode_t result;
            result = GSM_Configure(GSM_CONF_TIMEOUT_FACTOR, (void *) 110);

             

            GSM_Configure doesn’t run at all. It is totally ignored. It is like I have having commented out (//) this function. So I don’t get any return value. 

          3. Hi,

            Finally, I found that the problem with the GSM_Configure() function was
            an indexing problem of Eclipse. But I still get a "GSM_TIMEOUT_ERROR" as
            a return value of the GSM_ConfigSMS() and GSM_SendSMS() functions
            although I have increased the timeout factor up to 80% through the
            GSM_Configure() function. Have you got any idea why I am getting this
            value?

             


            Thanks in advance,
            Sotiris

          4. Hi,

            Finally, I found that the problem with the GSM_Configure()
            function was an indexing problem of Eclipse. But I still get a
            "GSM_TIMEOUT_ERROR" as a return value of the GSM_ConfigSMS() and GSM_SendSMS()
            functions although I have increased the timeout factor up to 80% through the
            GSM_Configure() function. Have you got any idea why I am getting this value?

             

            Thanks in advance,
            Sotiris

          5. Dear Cosmin,

             

            I am trying to find a solution to the problem I explained in my  previous post.Have you got any idea what caused this timeout error or can you advise me where I can find some help to this problem?

             

            Thanks,

            Sotiris