Problems with continuous FTP transmission

7 thoughts on “Problems with continuous FTP transmission

  1. Hi,


    I am trying to achieve "continuous" FTP data upload from GE865. Ideally, one file with up 40 MB should be collected during 24 hrs, in a single and lasting session.

    But the transmission seems to break always after about 30 minutes, having gathered 200 to 400 kB of data.

    I use GPRS and have an unlimited subscription. Any idea from where to look for the problem?

    Best regards, Tom

    1. Do you think is wise to take this route? There are so many problems that might appear leading to a connection break down, maybe rendering the data for this session unusable.


      Anyway, what are you observing? Graceful close (no carrier) or simply data doesn’t transfer anymore? Maybe inter-packet timeouts? Can you observer anything on server?

      1. Hi Cosmin,


        thanks for your quick response. Actually, this 24 hr transmission is for a remote test purpose, not for a real production. I admit it is a questionable setup.


        But how to observe what goes wrong? I just notice from server side that the file update has stopped . It is a service from an ISP, so I cannot get a debug access there.


        Onthe GE865 side, I neither have any local trace. But I think I could have something on ASC1, as ASC0 is occupied by peripheral circuitry. What do you propose? Some printout in the script? The timing is also pretty critical, I am afraid not much printouts could be tolerated.


        Based on the LED, it seems that my script keeps running but no FTP transmission takes place.



  2. Further to my previous post: Is there a way to easily check FTP connection status? I tried intuitively AT#FTPOPEN? but it just returns ERROR.


    I could of course blindly reopen the FTP connection, but it consumes some unnecessary time. 



      1. Yes, I tried that also. But similarly, takes a bit time to get a response. However, it seems that the only alternative is either reopening or AT#FTPPWD as you said.

        1. There is no way to find that a connection is really alive, other that doing traffic on it. FTP protocol has the NOOP command exactly for such purpose, see here and here. Telit FTP client hasn’t NOOP implemented but FTPPWD is doing the same with some more traffic.