Problem with FTPPUT

8 thoughts on “Problem with FTPPUT

  1. I am using a device based on a GC864-QUAD(07.03.200) to FTP files to a server: 
    • FTPOPEN works every time, without fail.
    • FTPPUT seems to only work sporadically.  If I retry on the same connection, it will eventually work maybe one out of five or six times.  All other times I get Bad or no response from server
    I can access the server no problem with an FTP client.  I am puzzled with the FTPPUT because it does work sometimes under the exact same conditions.
    Anyone have any ideas?
    1. Hi Dan,


      Try passive and active modes. Check signal quality, try with another network if you can.

      Try the latest firmware, 7.03.201.


  2. Further details.  On one FTP server, all is working very reliably.  On a different server, I get poor results as described above.  The server with the unreliable results works fine with other FTP clients (in other words, it does not seem to be problematic with FTP in general).


    I have seen some references to QoS with respect to FTP.  Is there any reading you can point me at?   Given all things being the same other than the target FTP server, would QoS make any difference?


    I have tried both active and passive modes.  It does not seem to change the behaviour with the “unreliable” server.

    I don’t think that I can upgrage the firmware because I believe that would invalidate the device certification.  Is that true?  Can you point me at the firmware release notes so I can see if there are fixes related to FTP?

    1. Dan, are you sure that the routes to relieble and unreliable servers are the same? FTP is based on TCP and in case of packet delay over timeout, connection will be closed.


      A network sniffer program like Wireshark on your server machine will show packet transfer at lowest level.  

      1. They are two different servers at different hosting providers. I do not control the servers, so running Wireshark is not an option.


        It seems for FTP, I only control AT#FTPTO…. the default is “100” which, based on the docs is 10 seconds?


        When I connect to the problem FTP server with a command line FTP client, responses are always less than 1 second.


        When I connect using the modem, with AT commands, things like AT#FTPPWD work consistently between multiple failed AT#FTPLIST commands.


        Stabbing in the dark…Maybe I will play with packet size settings to see if that makes a difference.


         I will also wait to hear from Telit if there are known ftp fixes in the next firmware.


        1. About sw. upgrade, it depends if your application is used in US networks like AT&T that needs a certified firmware 7.03.200. For other network there are no firmware requirements.


          Delta sw can be requested directly to your distributor.


          It is hard to say where is the issue. Do you see any improvement increasing the FTP timeout from 10s to maybe 20s or more?


          Did you try an external FTP client using the module like a modem (dialup connection) on your PC? Otherwise we cannot consider it a valid test since you are not using the same GSM network but maybe a LAN.


          Also what is the AT#FTPMSG response after a #FTPLIST failure?

          1. I am on Rogers in Canada, so there are certified firmware requirements. I cannot upgrade.

            I did not try using FTP as you suggest with the module as modem.  What is the easiest way to accomplish this on Windows?   

            After #FTPLIST failures, the message seems to be consistently: 



            #FTPMSG: 150 Opening ASCII mode data connection.



            I tried AT#FTPTO=200, and still had inconsistent results.  In generel, the error message appears well before the twenty second timeout.

            I also switched to binary mode.  Same mixed results.  After failure:



            #FTPMSG: 150 Opening BINARY mode data connection.



            I have tried yet another FTP site with seemingly good results.  I am a bit baffled about this one.  Unfortunately, it’s the one I need to make work.  Any other suggestions are appreciated.


            Thank you. 




          2. I did not try using FTP as you suggest with the module as modem.  What is the easiest way to accomplish this on Windows?  


             You need to search how to install a dialup connection using the module as a GSM/GPRS modem for your installed Windows version – is nothing particular to Telit modules so a general procedure will work.

            Something like this.