PDP context activation.

4 thoughts on “PDP context activation.

  1. Hello everybody,


    I am working with a G30 module and I don’t seem to be able to activate the PDP context  with the AppZone libraries.


    When I use the AT commands with the module everything always work as expected.


    Of course the activation of the PDP context is not istantaneous, as it depends from the mobile network.

    However, when I check the return status of the function, apart from rare occasions, the function keeps returning (=remains stuck) in some kind of “ACTIVATION IN PROGRESS” status.


    In those rare occasions when it goes through, then everything else (namely, connection to internet) seems to work flawlessly. 


    I have also run the examples that come with AppZone, but they seem to have the same type of (un)reliability, if not worse, because the “ACTIVATION IN PROGRESS” status doesn’t seem to be an officially supported one (indeed is not mentioned in the documentation)


    I believe that the m2m_activate_pdp function should work almost like the corresponding AT command and not return until the IP address (or failure to get it) is returned. 


    Any help would be greatly appreciated. 


    Best regards 



    1. Hi Marco,


      Glad to hear the application i sent you worked.

      Contact me if you have anymore questions.

      1. Indeed it worked.

        It takes sensibly longer than with the direct AT command, but this is not a problem for me. We know that there are so many factors that can influence that time and most of them are outside our control.


        Thank you very much for your help. 

        1. Just to mention it for others reading the forum. 

          The problem was that I put most of the elaboration in the main thread, rather than in proc1.

          Moving it in the high-priority thread solved the problem