PC directly connected to the UC 864 Interface Board – driver Problem.

8 thoughts on “PC directly connected to the UC 864 Interface Board – driver Problem.

  1. Normally I use EVK2, and it works fine.

    now I got external Power to IF-Board (alone) and linked PC. It’s searching for drivers (which is a fantastic improvement) but it doesn’t work with the VCP drivers of EVK.


    thks for help!Laughing

      1. I started to work with Telit modems by using the EVK2 and it’s virtual com ports which were generated by the drivers of EVK2 (VCP refer to EVK2 driver installation document). For this I connect USB to EVK2. That works great.


        I connected my microcontroller via serial connection with UC864 and it works too.


        But now I tried – just for interest – to connect the PC directly to the Interface Board (which has USB Connectors). The docu of IF-Board is attached to the post.


         The device manager of XP lists three Data Interfaces.


         I guess this are virtual COM Ports too. Therefore I need another driver. I tried the drivers of EVK but they didn’t work.

        thks a lot!

        1. You have C0N106 linked with 107 and CON11 with 110, and use USB B-type J102 right?

          I sent you a download link, please read the enclosed document and try the files.


          1. thks a lot! It works.

            Windows recognize it as a modem and I made a Internet connection.

            Where do other colleagues find these drivers? 


            Can I change settings by sending AT Commands via

            telit auxiliary port (COM)

            telit diagnostics interface (COM)?


            I tried using hterm (terminal) but i didn’t get a return.


            greetings from annoying Simon! Tongue out