OTA server tool working problems

2 thoughts on “OTA server tool working problems


    Hello, I’m having some problem trying to perform a remote update using OTA server tool:


    First: most times the tool doesn’t send the sms to the remote unit (it says: Fail reason: Modem Disconnetced). Obviously the local modem is in default configuration mode (no appzone).


    Second: when the sms is sent succesfully only one time the remote modem tried to connect with the OTA server tool and perform an update.


    To try to understand and solve the problem I’m trying many ways:   

    1. testing G30:

    If I try to send an sms using at commands directly to the G30 (simple text with CMGF=1) all works fine (so the modem, the sim and the sms message center is all configured).

     2. testing OTAserver tool:

    I tried to read from RS232 port using a terminal to see what "at command" the tool send to the modem and repling by hand with "OK" I can see all the data sent from OTA tool to the modem:














    In this way the OTA tool say "sent succesfully".


    Decoding the PDU formatted text I found this (two sms concatenated) :








    So I was thinking that If you can say to me the meanings of the 2 or 3 ASCII chars at the start of every message (something like "start upgrade command"?) it should be possible to send the sms from any other terminal, cell phone or modem, in order to start an upgrade request, right? 
    Thanks in advance,


    1. Hello Alessandro,


      To make  the OTA upgrade, you need to consider few factors, including the network the server runs on and the client application and see that they are all defined according to the instructions in the AppZone user manual.

      We have now a new Delta OTA tool and a new firmware & documents to use for OTA upgrades.

      You can contact me directly via mail – Or.Prat@telit.com

      and i will give you all the information and files needed so you can can check

      the OTA upgrade with the new environment.