NE70-868 message broadcasting over default Recipient ID

8 thoughts on “NE70-868 message broadcasting over default Recipient ID

  1. Dear Sir,

    We are using NE70-868 RF module on AMR. We want to broadcast message to all device that is connected in network.

    The issue is that, when we disible default reception ID, module is working file.

    coordinator log:

    2/20/2015 16:46:11.439 [TX] – mÿÿAT/V

    2/20/2015 16:46:11.459 [RX] – n00GJ.M0A.03.195

    2/20/2015 16:46:12.963 [TX] – mÿÿATF

    2/20/2015 16:46:12.977 [RX] – n00OK

    2/20/2015 16:46:24.066 [TX] – mÿÿATS306=2

    2/20/2015 16:46:24.108 [RX] – n00OK

    2/20/2015 16:46:25.877 [TX] – mÿÿATS202=5

    2/20/2015 16:46:25.902 [RX] – n00OK

    2/20/2015 16:46:26.799 [TX] – mÿÿATS214=100

    2/20/2015 16:46:26.825 [RX] – n00OK

    2/20/2015 16:46:28.003 [TX] – mÿÿATS307=3

    2/20/2015 16:46:28.028 [RX] – n00OK

    2/20/2015 16:46:30.974 [TX] – mÿÿATS310=1

    2/20/2015 16:46:30.998 [RX] – n00OK

    2/20/2015 16:46:32.611 [TX] – mÿÿATS330=1

    2/20/2015 16:46:32.637 [RX] – n00OK

    2/20/2015 16:46:33.974 [TX] – mÿÿATO

    2/20/2015 16:46:33.987 [RX] – n00OK

    2/20/2015 16:46:40.486 [TX] – eE1HELLO DEAR      /// working // we are able to send data to other module (E1)

    2/20/2015 16:46:42.223 [TX] – eE1HELLO DEAR   // /// working // we are able to send data to other module (E1)

    2/20/2015 16:46:46.363 [RX] – eE1d500ELLO   // We are able to received data from E1

    Router log :

    2/20/2015 16:42:40.237 [TX] – mÿÿAT/V

    2/20/2015 16:42:40.353 [RX] – nE1GJ.M0A.03.195

    2/20/2015 16:42:41.740 [TX] – mÿÿATF

    2/20/2015 16:42:41.851 [RX] – nE1OK

    2/20/2015 16:42:45.025 [TX] – mÿÿATS306=1

    2/20/2015 16:42:45.051 [RX] – n00OK

    2/20/2015 16:42:46.095 [TX] – mÿÿATS202=5

    2/20/2015 16:42:46.121 [RX] – n00OK

    2/20/2015 16:42:48.163 [TX] – mÿÿATS214=100

    2/20/2015 16:42:48.191 [RX] – n00OK

    2/20/2015 16:42:49.237 [TX] – mÿÿATS307=3

    2/20/2015 16:42:49.263 [RX] – n00OK

    2/20/2015 16:42:50.424 [TX] – mÿÿATS310=1

    2/20/2015 16:42:50.451 [RX] – n00OK

    2/20/2015 16:42:51.487 [TX] – mATS301=0

    2/20/2015 16:42:51.505 [RX] – n00OK

    2/20/2015 16:42:52.862 [TX] – mÿÿATS347=3

    2/20/2015 16:42:52.888 [RX] – n00OK

    2/20/2015 16:42:54.034 [TX] – mÿÿATS312=49

    2/20/2015 16:42:54.061 [RX] – n00OK

    2/20/2015 16:42:55.130 [TX] – mÿÿATS311=69

    2/20/2015 16:42:55.157 [RX] – n00OK

    2/20/2015 16:42:56.522 [TX] – mE1ATO

    2/20/2015 16:42:56.537 [RX] – n00OK

    eÿÿHELLO DEAR     // working fine. //we are able to received data

    eÿÿHELLO DEAR // working fine. //we are able to received data

    2/20/2015 16:46:46.200 [TX] – eÿÿd500ELLO   // working fine//we are able to send data

    2/20/2015 16:46:47.393 [TX] – eÿÿd500ELLO   // working fine//we are able to send data

    #########################################################################################

    But when we configured default Recipient ID as mention below, module comes in network but not communicating each other. even we are not able to send AT command to router (E1) and broadcast any message as well from both side, we are able to send AT commend to router (E1) only and ofter power off the coordinator.

    default Recipient ID configuration in Coor :

    2/20/2015 16:54:23.945 [TX] – mÿÿATS315=49

    2/20/2015 16:54:24.065 [RX] – nÿÿOK

    2/20/2015 16:54:23.945 [TX] – mÿÿATS315=82

    2/20/2015 16:54:24.065 [RX] – nÿÿOK

    2/20/2015 16:54:27.518 [TX] – mÿÿATO

    2/20/2015 16:54:27.627 [RX] – nÿÿOK

    default Recipient ID configuration in router (E1):

    2/20/2015 16:54:59.612 [TX] – mE1ATS316=49

    2/20/2015 16:54:59.726 [RX] – nE1OK

    2/20/2015 16:55:02.939 [TX] –

    E1ATS315=82

    2/20/2015 16:56:38.566 [TX] – mE1ATS315=82

    2/20/2015 16:56:38.689 [RX] – nE1OK

    2/20/2015 16:56:44.424 [TX] – mE1ATO

    2/20/2015 16:56:44.535 [RX] – nE1OK

    Please let me know, what we did wrong in above setting.

    Also, how can i send broadcast message in anetwork.

    Thanks & Best Regards,
    Diwakar

    1. Hi,

      by default  modules can communicate with each modules registered into the network, (including module ID into frame sent).

      If you would like to set a module as default recipient (in this case the data sent by each modules into the network is received always by default module) you have to specify the ID of this module in register 315/316 of all modules.

      For example, if you have a network with 1 Coord, R1 and R2, in order to receive data always on R2 you have to send ATS315=82 and ATS316=49  on Coord, R1 and R2.

      1. Dear Sir,

        I have implemented same as you mention but it is not working.

        Do you have any log or AT command sequence, it really help me to resolve issue.

        Thank,

        Diwakar

      2. Dear Sir,

        I have implemented same as you mention but it is not working.

        mATS316=49<CR>

        mATS315=82<CR>

        Do you have any log or AT command sequence, it really help me to resolve issue.

        Sorry for typo error, i have mention mÿÿATS315=49 instead of 82 in last post.

        Thank,

        Diwakar

        1. Hi,

          please try to do following sample:

          Before all, sending ATR in order to set default value on all modules.

          After it setting Coordinator, Router 1 and Endpoint 1 

          I set a network with a Coord and a R1 and E1 connected to it.  I set E1 as default recipient

          Coord:

          ATS306=2

          ATS315=69

          ATS316=49

          Router1:

          ATS306=1

          ATS311=82

          ATS312=49

          ATS315=69

          ATS316=49

          End device1:

          ATS306=0

          ATS311=69

          ATS312=49

          ATS315=69

          ATS316=49

          ALL other setting are as default!

          1. Dear Sir,

            I created one network, in which i keep two device (coordinator and router), configured command as suggested by you. But once i configured, and reboot both module, I am not able to communicate with router device. it is responding only and after we power off coordinator device.

            one other thing is that, is there any hardware specific requirement for communicate to default ID.

            We are using only RX and TX.

            I have attached log file. 

            Please let me know your feedback.

             

            Thanks,

            Diwakar

             

          2. In your case, (with only 2 modules) in order to receive data you have 2 way:

            -set R1 as default recipient 

            -do not insert any default recipient module, and write a data with the correct encapsulation (from coord to R1 it will be eR1HELLO, from R1 to coord it will be: eyyHELLO)

            In the first way  you can write (from coord to R1) e00HELLO and since R1 has been set as default recipient the data is received to R1. 

            SETTING:

            COORD: ATS306=2, ATS310=48, ATS315=82, ATS316=49 Other setting as default

            ROUTER: ATS306=1, ATS311=82, ATS312=49, ATS315=82, ATS316=49 Other setting as default

            Instead if you want to send bidirectional data (from Coord to R1 and vice-versa) you have to set on both modules ATS315=48, ATS316=48 and send the data with Recipient ID (from coord to R1: eR1HELLO)