NE50-868 Mesh connection problem

6 thoughts on “NE50-868 Mesh connection problem

  1. Hello,


    I have the following test setup :

    Computer — COORD ——————– Rooter00 ——————— EndDev01 — EndDev02 

    When I switch off the Rooter, I dont have access to EndDevices.



    All devices are switched on and ASSO leds are up continuously. 

    I send AT/V commands in stuffing protocol to other devices.

    I got answers from Rooter and EndDev02. Nothing from 01!



    I’ve replaced places of 01 and 02, all ASSO leds are "1".

     Computer — COORD ——————– Rooter00 ——————— EndDev02 — EndDev01 

    I got answers from Rooter and EndDev01. Nothing from 02!

    I got wrong data from Rooter also :  «n01GC.M0<SOH>.03.q74<CR>

    Should be :  «n01GC.M0A.03.174<CR>



    Switched off the Rooter.

    ASSO leds of 01 and 02 are up (waited 5 minutes).

    I cannot get answer from 01 or 02, but they seemd connected.



    All switched on. All ASSO leds are "1".

    Tried to send broadcast data and hayes by using 0x00 0x00 as Device ID.

    No any answer. Expected to get AT/V answers from all 3 devices.


    * How to understand the connection status of a module when I install a huge network?

    * How to send broadcast data and how to get answers? 

    * Why I got wrong data? I’ve selected "Acknowledge"  S332 = 1 on Coordinator, Low Power Mode is off S340 = 0 for all devices.

          1. Hi 

            could you try to send data without new serial protocol?

            Is the result the same?


          2. Hi,


            I’ve tried with timeout option. Disabled the new serial protocol.


            I’ve changed the router’s ID to 03. 



            I’ve put them the same place 20 meters away from the coordinator. All 3 modules are nearly placed.

            Network discovery tool finds only the 02 one. Sometimes 01 one with "incomplete information", but ALL seem connected (leds are "1" continuously)




            I’ve moved the router to the center (10m away from coordinator and nodes).

            I can get data from 02 and 03 (router), but not from 01.

            Leds are up still..

            Network discovery tool finds all, sometimes 01 is with "Information Incomplete".



            I’ve replaced the places of 01 and 02. (02 is at the place of 01 and vise versa)

            Network discovery tool finds all

            I can get data from ALL, sometimes 02 does not answer or delays so much.

            Leds are up still.. 



            It’s almost the same with timeout option too.

            I think ASSO led is "1" when a beacon received from coordinator. Without handshaking.

            So the module does not try to TX data to coordinator and wait ACK to understand that is connected. Just if gets a signal from coordinator, the ASSO led is up.

            I’ve tried it by removing antennas of all the modules. Only coordinator has antenna.

            They seem connected but they cannot answer, or their answer does not received by the coordinator.