module is hanging…

9 thoughts on “module is hanging…

  1. Hi There

    We’ve a problem that affects our Telit GE863-GPS module (latest Firmware: 7.03.702).

    The problem is that this module stop working. When the module doesn’t have a connection to the server or the gsm for longer time (about 6..7..8 hours), the STAT_LED gets permanently off. All other LED’s are also OFF.
    In this case, the only way to get a communication to the module is to press the ON/OFF button on the module. It seems like the module is hanging.
    When the module doesn’t have a connection to the server or the gsm, in this time, makes the module several times a reboot (AT#REBOOT), with an interval from circa 2 minutes.
    Each AT#REBOOT the module writes also data to the internal flash. (for saving data)

    We have tried with a longer reboot-interval with the sleep(..) method, but it doesn’t help. Can it be, that the module does not like the many reboots? I’m wondering that noone else have a similar problem…

    Any assistance would be greatly appreciated.


    1. Looks like a difficult memory issue; are you using Python or external host?  What if you skip flash writes (are you leaving enough time to settles before reboot?)? What is you skip reboots?

  2. Yes I’m using Python. I have no sleep time between flashwrites and reboot. I’ts better to calculate a little sleep?


    that’s the code to flashwrites and reboot:


    But first, I’ll try without flash writes. I’ll post the result after the test….

      1. same result without flashwrites! But i’ve found out, that the module
        always gets hanging between the flash writes and the reboot. therefore I
        think you could be right, with a sleep before the AT#REBOOT command.
        I’ll try it…


        In another post i found a text, which says its better to use the watchdog to reboot than the AT#REBOOT command. like this:




        what’s about that? is that right? should I better use this code?



  3. okey, I’ve tried it with a sleep time of 2 seconds after the flash writes and then I used the watchdog-reboot method:




    and it works great since about 16 hours! I think you were right, thanks Cosmin!