LE910-NAG Firmware Upgrade Faliure

2 thoughts on “LE910-NAG Firmware Upgrade Faliure

  1. I have a LE910-NAG module and I was testing it with an internal BTS configured to simulate certain network that support NAG bands, I had old modules was working before and it’s now working in our cutomers, but I got a new module and was testing it with no luck using AT+COPS=? command, the command was returning Error and “no operation allowd” at AT+CMEE=2, later I discovered that the module has an older firmware version, it was 17.00.500 so I upgraded it to 17.01.502 and it gave me the same error so I tried to flash 17.00.503 firmware and 1st it stopped at the end of process which is “restoring factory defaults” then I pushed download again and it stopped when the software was “searching modem” in the middle of the process and the module no more working!

    Any help regarding this issue?

    1. The module isn’t detectable by PC, is there anywan to re-flash it again and bring it back to normal mode?