LE910-NA1 not able to connect to the network

15 thoughts on “LE910-NA1 not able to connect to the network

  1. Hi,

    I am trying to setup the LE910-NA1 to work with our product. Our driver is able to communicate with LE910-NAG and setup a data call without any problem. However, I am having trouble getting the LE910-NA1 to connect to a data network.

    We are able to dial in to the network with ATD*99# and the authentication process is successful (CHAP challenge). However, we get no response from the network after we send out the NCP Config request.

    Out of curiousity, I tried something different and sends the AT#SGACT command after AT+CGDCONT instead of dialing the ATD*99# and it seems like I was able to get the IP address from the network no problem.

    Is anyone aware of any difference (default settings…) between NAG and NA1 that might explain my problem?



    1. Hi, I suppose that you are registered in 4G, so your issue should be AT+CGDCONT related or more precisely, CID 1 related.
      In 4G,  CID 1 is activated automatically at registration phase. When you start your PPP procedure on CID 1 and if the module is already registered in 4G, you shouldn’t re-set the APN of CID 1 with  “AT+CGDCONT=1,…”.

      Basically you should have set the APN on CID 1 before the registration and then send only the ATD*99# (or ATD*99***1#) to start the PPP.
      Or, as an alternative, use PPP on CID 2, but the APN on CID 2 must be different from the APN on CID1.

      1. Hi Taj,

        Thanks for your reply. Yes, we are registering to 4G network. I tried your suggestion to use CID #2 and it makes no difference. 

        The thing that I don’t understand is LE910-NAG is also a 4G capable modem. If our modem driver is able to connect to the data network with NAG, why NA1 behaves differently? Or there is some difference between the NAG/NA1 that might explain the problem I am having?



        1. Hi,
          The majority of operators are planning to use CID1 for IMS (VoLTE, SMS, …) and therefore it is better to use a different CID for custom data.
          For example, on Verizon products it is set to CID 3 by default.
          We try to have the behavior of all our modules aligned, but sometimes it is not possible.

          Anyway, can you try the following procedure:
          // Wait the module registers
          // start your PPP procedure

          If this procedure fails, please send us an AT command log and please specify also the SW version of this module (AT+CGMR).


          1. Hi Taj,

            Thanks for your explanation. I follow your steps and it’s still getting no NCP response from the network. Attach shows the AT command that we send to NA1 module.

            You won’t see the AT+CGDCONT=1 and AT#REBOOT and AT+CGCONTRDP=1 in the log file as I perform them seperately before I start our modem driver.

            Here’s the response I got from AT+CGCONTRDP=1

            +CGCONTRDP: 1,5,”lteinternet.apn.mnc720.mcc302.gprs”,”″,”″,”″,”″,”″,”″

            +CGCONTRDP: 1,5,”lteinternet.apn.mnc720.mcc302.gprs”,”″,”″,”″,”″,”″,”″


            The firmware version is 20.00.522



          2. In your case, for CID 1, the network assigned you the same APN as you used on CID 2.

            On CID 2, you have set this APN:
            On CID 1, the module received the following APN from network:
              +CGCONTRDP: 1,5,”lteinternet.apn.mnc720.mcc302.gprs”….
            They are the same and in LTE, they should be different.

            I suggest you to move PPP back to CID 1 (ATD*99***1#), but don’t set the APN for CID 1 with AT+CGDCONT.
            Just comment out AT+CGDCONT from your code.

            If you have any question, let me know.


          3. Hi Taj,

            Thanks. I have two questions for you.

            1) I thought when you asked me to enter AT+CGCONT=1. This will clear the CID1 entry. So, for the fact that the APN is still present, is it means that LE910-NA1 will automatically retrive the APN from the network?

            2) I still not able to get the NCP response from the network on CID1. However, I tried to bypass the NCP procedure altogether and use the AT+CGACT=1,2 (for CID2 only, I don’t need to do this for CID1) to activate the channel and AT+CGCONTRDP=1 or 2  to retrive the IP/DNS server address and that seems to work no problem. Do you know if there is any potential problem if I don’t perform the NCP procedure?



          4. Hi,

            “AT+CGDCONT=1” clears the settings for CID 1 and then the NW assigned you a default APN for this CID.

            Regarding “AT+CGACT”, CID 1 is activated automatically during LTE registration, so you don’t have to issue “AT+CGACT=1,1”.
            Regarding “AT+CGACT=1,2”, since the APN that you are setting for CID2 is the same that the NW assigned you for CID1, you should not activate this second CID.
            In this case, you should use CID1 only; you can use CID2 with a different APN.

            For the NCP issue, can you attach a PPP log, so I can inspect the PPP negotiation?
            In a previous post you mentioned CHAP, but it seems to me that you operator doesn’t require authentication.
            Can you make a test without authentication? Disable authentication in your PPP settings and set the module to AT#GAUTH=0.



          5. Hi,

            but it seems that it’s  your uC that sends the LCP Termination Request (0x C0 21 05 ).
            This frame (line 66):
            Velos : Raw Tx : LCP TERM REQ 0000 7e ff 03 c0 21 05 03 00 04 85 72 7e

            From my point on view, since CID 1 was activated without authentication, you don’t need authentication.
            Can you change AT#GAUTH setting to 0 and disable authentication in your PPP script (noauth in pppd)?

          6. Hi Taj,

            Sorry, I forgot to mention. I included two captures. One with authentication and one without. Yes, you are right, I termininate the LCP request because I didn’t get any repsonse from the network.



          7. Hi,
            I suppose that the AT#GAUTH was also set accordingly – 0 or 2.
            Anyway, can you make a test with Windows’s PPP (Dial-Up)?
            Then, if you have this same issue on Windows, please send us an email to “TS-EMEA@TELIT.COM” and I will send you back a Windows tracing tool, to collect a trace from this module.
            The trace can be collected over USB.

  2. Hi Taj,

    Attached is the PPP log from my computer. It seems to me that the first ncp request is actually timed out. (Recv timeout event received for portid=12,Id=6,Protocol=8021,fAuth=0). However, a retry seems to be ok. 

    Can you look at the log and comment on it? Do you think it’s the network or the modem that causes the time out? I will try to add a retry to my driver and see if it resolve my issue.

    Thanks for your help


    1. Hi,
      Actually the PPP communication is only between the module (DCE) and your micro / your PC (DTE).
      The PPP connection doesn’t reach the NW. The module converts the packets into a different protocol suitable for mobile NW.
      Unfortunately, based on this information, I can’t determine why was that packet delayed or not received at all by the module.
      To better understand the issue, I will need a trace from the module and then check the PPP log on its side.

      1. HI Taj,

        I tried to add a retry to send the NCP config and that seems to work for me. Unless I find some other problems later, I think you solved my problem. 

        Thank you for your help.