HTTPSND error with custom Content-Type

14 thoughts on “HTTPSND error with custom Content-Type

  1. I am using a DE910-DUAL. I have been able to successfully use HTTPSND with one of the standard (numeric) content types, as follows:


    This results in the HTTP header line:

    Content-Type: text/plain; charset=utf-8

    However, I need to use “text/xml”, which is not one of the numeric types. The AT command reference says I can use “other content” to specify other content types:

    post_param: Numeric/string parameter indicating the HTTP Content-type

    identifier, used only for POST command, optionally followed by colon character and a string that extends with sub-types the identifier:

    “0[:extension]” – “application/x-www-form-urlencoded” with optional extension

    “1[:extension]” – “text/plain” with optional extension

    “2[:extension]” – “application/octet-stream” with optional extension

    “3[:extension]” – “multipart/form-data” with optional extension

    other content – free string corresponding to other content type and possible sub-types

    So I have tried various other formats, but they all return errors. For example:



    +CME ERROR: operation not supported

    What is the proper format for the “other content” in the post_param parameter? Can someone show a working example?



    1. Hi,

      I checked the below command works on the DE910-Dual.


      What is your firmware version?

      Would you please check “AT+GMR” command?

      1. Here is my version:



        Can you confirm that the format of the “other content” is correct? It is free-form text?

        Here is the full set of commands:

        +CREG: 0,1
        +CSQ: 13,99
        #SGACT: ""
        +CME ERROR: operation not supported

        1. Hi

          This link is for the lastest firmware.

          Would you please check again with the new firmware?

          I checked it works well on this version.


          #HTTPCFG: 0,””,80,0,””,”******”,0,120,1,300,0,0

          #SGACT: “”



          1. Thanks, Changjun.

            Do you have instructions for the upgrade? I tried following instructions in section 6.1 Step-by-Step Upgrade Procedure (TFI) of Telit DE910 Software User Guide. But the modem was not recogized. I verified with TeraTerm that the modem was on COM3. I got a “Modem not Found” error at startup, then I switched to COM3 and tried download, but I got a “Modem Status – Invalid” error.

            I am actually using a Skywire NL-SW-EVDO-V development kit. Do they have a different upgrade mechanism?

            BTW, I retried the commands in the same order as you (still with 15.00.024) and I still got the error, however I got slightly different results from the AT#HTTPCFG? command:

            #HTTPCFG: 0,"",80,0,"","******",0,120,1
            #HTTPCFG: 1,"",80,0,"","******",0,120,1

            #HTTPCFG: 2,"",9978,0,"","******",0,120,1

            Mine is missing “<pkt_size>,0,0” at the end? Maybe due to older firmware verison?


          2. OK, now I realize that I need to use the other USB connector, so the device is now recognized as a Telit modem.

            I run the upgrader app, it recognizes the modem and looks like it begins to update, but after about 30 seconds it throws a Parameter Request Error.

            Screen cap here:

            I tried at the default 230400 bps first with the same result.

            Any more ideas?

            I am trying this on Windows 10, but I now noticed that the doc says only up to Windows 8. Is it supposed to be compatible with Windows 10?

            (Ideally, you could give me a version that would work for Mac because that is my primary machine!)


          3. Hi Mat,

            When you execute the TFI file to update, it leave the “DownloadLog” file.

            Please send me that.

            And then, can you try again via UART1 port of DE910 with 115200 speed?

            It will need more time to update the firmware.

            Please be careful not to send any command during the time.

            Also you have to keep the power.

            Unfortunately, There is no a version for MAC.

          4. Changjun,

            Thanks. I’m attaching the download log.

            Here is a little more information:

            1. FYI, the schematic for the development board is at: I am also trying to work with their support.
            2. I apply power to the board.
            3. I connect USB to J15.
            4. I hold the switch on the development board to power up the DE910.
            5. I run the DE910-DUAL_15.00.026_TFI.exe.
            6. It discovers the device on COM3 and sets BPS to 230400 and prevents me from changing it.
            7. I attempt the download and get the error I’ve described.
            8. If I reboot the DE910, I can attempt 115200 and I can try checking the UART option (doesn’t make sense), but neither work.
            9. I noticed that about the time I get the error, the device disappears from the Device Manager screen.

            Any other ideas?


          5. Mat you should try the update on the same port the module communicate with AT commands, is this COM3?

            The procedure is the other way: start and prepare TFI, click programm in TFI then long press module power on button.

          6. I was able to upgrade to 15.00.026. The problem was that the driver does not work properly on Windows 10.

            The upgrade solved my initial problem. I now get the proper “>>>” prompt after the HTTPSND command. I am continuing to work through the full transaction details.

            Thanks for your help.

          7. Hi Mat,


            I’m not sure if you talk about a device at the above link.

            If yes, this page said that this development kit can connect to the modem directly from PC to the modem’s UART port, sending AT commands through PC terminal application.

            Please make sure if you used this port to upgrade.

            and you have to check if there are any sending at command during firmware updating.

            Or, please re-try the firmware updgrading on the windows 7 PC.

            When you update the firmware with TFI, you have to check some precautions like belows even on the UART.

            1. Connect USB cable.
            2. Power up the module and other modules should power off in this stage for preventing confusion.
            3. Close all applications which use USB Diagnostic port.
            4. Start TFI app and follow instructions. App will detect USB port to download automatically.
            5. Before clicking Download, check power stabilization and cable, etc.
            Once programming process is started, doesn’t not have to be interrupted.
            6. Then, Click Download.
            7. Wait for pop up window displayed as “Download successfully completed”
            8. If you meet error, please report “ErrorLog.txt” and “DownloadLog.txt” in TFI directory to Telit.


          8. Thanks for the reply. I pointed out in the previous reply that I was able to upgrade with a Windows 7 machine. The upgrade solved the initial problem.