10 thoughts on “HE910_EUG AT COMMANDS delay

  1. Hello Telit and Merry Christmass,


    After updating some modules (HE910_EUG) to firmware verstion   12.00.214 we got porblems in Python script to send AT commands (through MDM module ) and with SER module aswell. It’s extreamly big delay appears between command sending. 


    To make problem clear we made a python script test:



    import time

    import MDM



    def mdm_receive(timeout):

        res = ”

        start = time.time()

        while (time.time() – start < timeout):

            readData = MDM.read()

            if len(readData) > 0:

                start = time.time()

                res = res + readData

                if res.find("OK") > -1:

                    return res

                if res.find("ERROR") > -1:

                    return ”

        return ”





    print ‘START TEST’


    start_time = time.time()




    while n<100:

        MDM.send("atr", 10)




    print ‘STOP TEST time: ‘ + str(time.time()- start_time)


    #timeout for see result




     Experiment module 1 firmware 12.00.213:







    Experiment Time : 0 seconds commands implementing immediately .  



    Experiment module 2 firmware 12.00.214:







    Experiment Time : 30 seconds ! 



     In experiment script we are waiting  for OK response. In both experiments this OK is comming and no errors. But module with version 12.00.214 have extra delay ….

     In old verstion 12.00.213 everything looks ok


     Both modules registered in the network.

     The same problem with the strange delay in SER port .


     p.s during the firmware update no errors occure. everything looks fine.


    Thank you for help  



    1. Does it happen only at module startup or at any execution, with the module already fully started and registered? With and without SIM? What are &K and CFLO settings?

      1. Does it happen only at module startup or at any execution, with the module already fully started and registered? With and without SIM? What are &K and CFLO settings?

        it happens at any execution  ( module is fully registered in home network) 

        Tried also with and without sim card,

        In experiment I used &K0  and CFLO=0 , but also tried &k3 and cflo=1.

        The same result …





        DTE SPEED                      : 115200
        DTE FORMAT                     : 8N1
        GSM DATA MODE                  : Not Transparent
        AUTOBAUD                       : +IPRxxx00=NO
        COMMAND ECHO                   : E1=YES
        RESULT MESSAGES                : Q0=YES
        VERBOSE MESSAGES               : V1=YES
        EXTENDED MESSAGES              : X1=YES
        LINE SPEED                     : F0=autodetect
        CONSTANT DTE SPEED             : YES
        FLOW CONTROL OPTIONS           : &K0=NO
        ERROR CORRECTION MODE          : RLP
        CTS (C106) OPTIONS             : &B2=OFF while disc.
        DSR (C107) OPTIONS             : &S3=PHONE ready->ON
        DTR (C108) OPTIONS             : &D0=ignored
        DCD (C109) OPTIONS             : &C1=follows carrier
        RI (C125) OPTIONS              : R1=OFF dur. off-hk
        C108/1 OPERATION               : &D0=NO
        POWER SAVING ON DTR            : +CFUN:1=NO
        DEFAULT PROFILE                : &P0=user profile 1



        But this parameters is for SER port or it also depend on MDM  ?
        But I tried several parameters and looks like the same delay.
        Is it some extra parameters to control delay between the commands ?
        Is it possible to get previous firmware to check that module is working ?
          1. The message was sent to you registering email address p**@tel***x.com, check spam/junk folders.

            Interesting… but I did not find even in spam

            Can you resend please , or if it’s possible send a private message in this forum ? 

          2. Re-sent to the same address.

            I downgraded to version 12.00.213 works OK with out delays …


            Where can be a problem?


            We need 12.00.214 because I2C is working there throw IIC python module ( on 12.00.213 I2C through AT commands was not working well, we are getting strange bytes on reading ) 





          3. This version is slightly faster, uses 20 seconds, but still much longer than the previous firmware, we’ll investigate the next week:


            import time
            import MDM

            def Chat(command, expected, timeout):
                timer = time.time() + timeout
                MDM.send(command, 5)
                b = command + MDM.read()
                while (time.time() < timer) and (b.find(expected) == -1):
                    b = b + MDM.read()
                return b

            #MAIN START TEST

            print ‘rnSTART TEST with CHATr’
            print ‘START AT %fr’ % time.time()
            n = 0
            start_time = time.time()

            while n < 100:
                Chat(‘ATr’, ‘OK’, 2)

            print ‘STOP AT %fr’ % time.time()
            print ‘Took %f secondsr’ % (time.time()- start_time)

            #timeout for see result