HE910 CMUX Disconnect

3 thoughts on “HE910 CMUX Disconnect

  1. I think I noticed a CMUX issue.


    After I set up a CMUX connection and let it run for a minute or so, I cannot get it to disconnect without resetting the whole modem.  


    While having a working CMUX connection I have tried sending a DISC packet (0xF9, 0x03, 0x53, 0x01, 0xFD, 0xF9), a UIH CLD packet (0xF9, 0x03, 0xEF, 0x05, 0xC3, 0x01, 0xF2, 0xF9),  and I have tried pulling DTR low for 2-30 seconds without CMUX stopping and returning to the command line.  Regardless, I continue to see data coming in and I’m able to issue AT commands to the virtual UARTs.


    I’m using FW 12.00.003-B062, but I believe this is also present on the release 12.00.003. 


    Here are the AT Commands I’m using to start CMUX:





    1. Hi Jeff,


      you can find attached a CMUX log captured with Portmon tool, using the TelitSerialPortMux.


      it shows CMUX frames when the channel is open and then closed. I hope it can be usefull for you.


      by the way, you can contact the technical support in north america to get the latest official version 12.00.004

      1. Andrea,

        Thanks for the CMUX log it helped me find the problem.  In the CMUX User Guide, it states "If the application sends a
        disc for the DLCI 0 (the control channel), all the established channels will be closed." 

        Apparently that is not the case, the application must first disconnect from the established channels and then disconnect from the control channel before the module will return to standard AT mode.