Hardware flow control not working

5 thoughts on “Hardware flow control not working

  1. Hello,


    I’m using the Telit GC 864 QUAD-V2 Module(Firmware:10.00.055), but everytime i try to upload data (aprox. 1MB) to an ftp server, about 80% of the data get lost. Although, I have activated the hardware flow control (AT&K=3), it is not working. 


    I also displayed the flow control lines CTS and RTS whith an Oszi, but CTS doesn´t change even if the input buffer of the Modul is full…


    Is there a anything else to configure? 


    Looking forward to hearing from you soon.


    With kind regards,

    <span class=

  2. I use flow control (‘AT&K0’ – as NO flow control) on GPRS-connection (TCP/IP) and nothing was wrong!

    Also, I use  ‘AT#TCPREASS=1’ that provide more flexible data transmitting.

  3. First of all thank you for your fast answer.


    I tried your configuration but it is still not working.


    I want to use hardware flowcontrol because i know there is a data loss. The modul is not able to upload the data fast enough. So the data from the Microcontroller let the buffer overflow. But the modul is not activating the CTS line. So the Microcontroller keeps on sending data…. 


    I will now try it with software flow control, but It would be very interesting to know why it is not working.


    With kind regards,

    Maximilian Knaller 




  4. Hello, Maximilian!


    In GE864-GPS, I  put RTS on the ground as described in datasheet.

    Maybe, problem in something else? What about incorrect data on server part, or overloading input buffer (usually, about 4096KB)? Try to send your data in cycle throwgh TCP port on server application with acknowledges after ever part of data.

    Anyway, data packets will be splitted or concatened by network providers on its own opinion. 

    If you are using additional microcontroller, the problem maybe in it (microcontrollers usually don’t have input/output buffer and byte overrides by next byte). By the way, if frequency on UARTs modules are not the same (~1-3% and higher), that cause a data errors (especially on big packets of data).


    Hope it helps.


    Good luck to you!