SL869-V2 location fixing issue

3 thoughts on “SL869-V2 location fixing issue

  1. Dear Sir,

    We are using SL869-V2 module in VTS,  if we are using external active antenna, everything is working fine, but if we are using internal active antenna then we are facing location fixing issue. As below.

    Case_1 . Sometime Telit view is showing satellite in view but it is not being used to fix location.

    after removing antenna, it is still showing same satellite in view. Testing is done at same place, same device.

     

    Case_2. Telit view is now showing any satellite in view. Testing is done at same place, same device.

     

    Case_3.  Devices is working fine. Testing is done at same place, same device.

     

    I have attached three log in .zip file. Please let me know, what is the issue.

    Thanks,

    Diwakar

    1. Dear Sir,

      We are using SL869-V2 module in VTS,  if we are using external active antenna, everything is working fine, but if we are using internal active antenna then we are facing location fixing issue. As below.

      Case_1 . Sometime Telit view is showing satellite in view but it is not being used to fix location.

      after removing antenna, it is still showing same satellite in view. Testing is done at same place, same device.

       

      Case_2. Telit view is now showing any satellite in view. Testing is done at same place, same device.

       

      Case_3.  Devices is working fine. Testing is done at same place, same device.

       

      I have attached three log in .zip file. Please let me know, what is the issue.

      Thanks,

      Diwakar

      Dear Diwakar,

      From the attached logs it can be seen that:

      Case_1: Module knows that those satellites are in view but don’t reports CN0 levels, which means that is not able to correctly acquire satellite signal. This condition happens if module already navigated before (in a 2 hours period) and still have in memory valid broadcast ephemeris or extended (synthetic) ephemeris calculated by EASY.

      Case_2: Module is failing to acquire satellite signals, it doen’t even get GPS time as it can be seen from NMEA sentences:

      $GNRMC,002614.799,V,,,,,0.00,0.00,060180,,,N*5A
      $GNVTG,0.00,T,,M,0.00,N,0.00,K,N*2C
      $GNGGA,002615.799,,,,,0,0,,,M,,M,,*51

      where, unless test started at 00:06:03 UTC, 26:15 is likely to be the time passed since module startup.

      Case_3: Again GPS signal acquisition issues, in fact it can be seen that it take 8 minutes to get first valid fix.

      As you pointed out, the GPS module is working fine using external active antenna, so it seems that the issue is related to RF path using internal active antenna. I suggest checking internal antenna power supply, matching network and RF line impedance (that must be 50 ohms).

      To better inspect your application it is possible to open a full design review, that gives us the possibility to focus main potential issues in your design. To open a design review you have to compile the attached design review request form and send it to ts-emea@telit.com with:

      • Application schematics;
      • GERBER file
      • layup (stackup) file

      Best Regards,

      Simone Andrea Muscas
      Technical Support – EMEA Application Engineering

      Telit Communications S.p.A.

      1. Dear Sir,

        Thanks for your support. I will share design details for review.

        Thanks,

        Diwakar