GPRS Socket connection problem

6 thoughts on “GPRS Socket connection problem

  1. Hello,

            I am using Telit GL868-Dual modem for remote socket connection.

    I am facing the problem of GPRS Modem getting stuck after a few hours of operation in the Electricity panel room of our customer.  Also we see the problem of modem dropping and re-initiating connection every few minutes even though we are ensuring that there is data between the sockets after every few seconds.

    Sometimes, it continuously connects and immideately disconnects the socket when I try to connect to socket. When i checked the error log, it gives me “+CME Error: 559 i.e. timeout in opening socket”.

    I am using below AT commands to set the modem socket parameters;

    1. “AT#SCFG=1,1,1500,180,300,10rn”

    2.  “AT#SCFGEXT=1,1,0,0,0,0rn”

    3. “AT#SGACT=1,1rn”

    4. “AT#SD=”

    5. “AT#SH=”

    6. “AT#SSENDEXT=”

    7. “AT#SRECV=”

    Any help will be appreciated. Thanks in advance….

  2. I have also notice one thing; when I issue “at#sd=1,0,n,”a.b.c.d”,0,0,1″ command, on server side i am getting continuously 3 times ‘connection accepted and connection closed’ from modem and modem will give me ‘+CME error:559’ after 30 seconds.

    It connects to remote server when issuing “AT#SD=” command and then disconnects the socket immediately…

    What should I do?? where am i going wrong??

    1. Probably your issue is not something generic.
      Have you tried with different operators, just to determine if the issue is operator related?
      Can you collect a Wireshark or tcpdump log on your server side and check what is going on with the connection?

      Otherwise, we will probably need a trace from this module.
      For this purpose please send an email to and we will arrange the details by email.
      And please, specify also the SW version of this module, the command is AT+CGMR

      1. Thanks 

        Taj Prijon for reply.
        Kindly reply with possile solution as soon as you have replied to my post…I have already mailed the details on “”.
        I have crossed my deadlines for this project. Now this is TELIT’s team time to solve this issue within 1-2 days of deadline period.
        1. Hello Taj Prijon,

          The problem is solved. The problem was with our static server (i.e. Router) settings actually.

          Thank you “TELIT TEAM” for your wonderful support.


          Urvi Shah

  3. I have go through the technical forum about socket connection timeout error (i.e. +cme error:559), and it is found that many people are facing the same problem. But still no one has provided solution to this problem….

    So I think there is a major BUG in TELIT firmware regarding socket connectivity….

    Or is there any technical person in TELIT who knows about this problem and has capability to solve this problem??

    Because we are facing such a big trouble in front of our clients…Our product gets failed…. and no one is there, from telit team, to help us….

    Relpy as soon as possible….