GM862 GPS no longer responds to AT commands

8 thoughts on “GM862 GPS no longer responds to AT commands

  1. Hello


    Since few days i’m no longer able to etablish serial communication with GM862 GPS.

    ( version  7_03_402 )


    When the module starts it catch the GSM network but does not respond to AT commands.

    Sometimes GM862 sends : #MWI: 1,1 on the serial interface. ( not every time )


    I have tried to flash again the firmware but Xfp sofware is not either able to link with the module.

    It stays many seconds in ‘Linking ….’ mode and finalyget  "Error Flashboot – Boot timeout "


    Is there a way to reset the module as in factory defaut settings ?

    AT&F command of course won’t work.


    Many thanks for your support.

    1. Hi Laurent,


      It looks like module is ON  since it sentd URC on serial port.


      MWI is a Message Waiting Indication as described at AT user guide; ref to 


      #MWI – Message Waiting Indication command descrtiption.


      Maybe if you call it it is reachable (voice call) and you could have a RING mess on serial port isn’t it?


      So I can guess something happened on the receiver side of UART.

      Can you use an oscilloscope to investigate hte Tx line to see if levels are correct and signal is a correct serial transmission?

      1. Hello Luca


        I’ve made more tests.


        Actually sometimes the module responds to AT commands, but most of times it does not.


        I’ve checked RXD line ( PIC uart TX pin ) with an oscillloscope :

        It receives a clean UART signal through U3 level translator.

        ( 3.3V uart signal is converted to 2.8V uart signal )


        I’ve also noticed sometimes when i power the module up with push button, STAT Led starts to blink few times and sudentely stops : the module powers off iself !


        I don’t know what is wrong, i attach below the schematic i’ve made.

        The purpose is to connect this board to a PIC uart.


        Thank you for your help, i’m really stuck.



        1. Hi Laurent,


          from the schematic nothing strange appears. All looks so simple and correct;

          Have you verified hte power supply has been designed to be able to have a 2A load?


          Also, if you say you can see a clean UART signal through U3 level translator I think the module is answering the AT, or … ?

          1. The module is able to register the GSM network, detect an incoming call , all looks working fine except the serial interface.


            It is not able to respond to AT commands.


            It have tried to bypass level translator and used a MCP2200 USB/UART converter working at 2.80V.


            The module still won’t respond to AT commands.

            When i enter AT#SHDN nothing happens, it means the serial interface is not working in both way ( RX & TX )



  2. When i call the module and display messages from the serial interface with hyperterminal, i do not see "RING" message.


    When the incoming call happens, the cursor moves 1 step forward but does not display any character.


    something like bad speed or something similar.

    I’ve tried different speed but still no chance.


    Note that Xfp software for firmware upgrade won’t connect either.



    1. Have you tried your module on another support board? Have you tried another module on your support board?