GL865dual (with EVK2 kit) and TI C5515 DSP EVM serial interface problem

14 thoughts on “GL865dual (with EVK2 kit) and TI C5515 DSP EVM serial interface problem

  1. Hello Friends,


    I am trying to manage TI C5515 DSP Processor to communicate with Telit GL865 gsm module (with EVK2 kit) through UART serial port. Firstly, I connected Telit EVK2 to pc via RS232 and sent AT commands successfully. Then, I wrote UART data transfer firmware to DSP and communicate it with PC successfully. Eventually, I am trying to control Telit module with the DSP board, but I have a problem sending AT commands to the Telit. When I send AT#SHDN , nothing happens (I expect module shut down). So, I think there is no data sent to the GSM module. Am I doing something wrong with UART configuration of the DSP? or What would be the problem? Thanks in advance.

    Current configuration: 9600 baudrate, wordlength 8,1 stop bit, no parity, no loopback, no flowcontrol, no rts control


    Best Regards

    Yusuf Sekman

    1. Hi Yusuf,

      check if you don’t have the serial lines cross (a common mistake) , GL865 pad 7 C103/TXD is serial data input, pad 8 C104/RXD is serial data output. Allowed voltage, 2.8V.


  2. Hi Cosmin,


    Thanks for the quick answer. When I use a cross cable (connections are like that: Rx-Tx, DTR-DCD, RTS-CTS) between two modules, dsp receives the same of the command. Do you mean to do that?

    In other way, when I connect them directly in straight order, the result is as you see in my first question.

      1. When DSP sends a command to GSM module such as AT#SHDN, answer read from the GSM module is the same (
        AT#SHDN), i mean it receives what it sends.

  3. Is good then; send the termination character (carriage return r hex 0D dec 13) after the command and should be executed.


    Corrected values.

    1. I send the strings like this: 
      char buffer1[7] = "AT#SHDN";
      char send[2] = "r";
      Is that not right?, it does not work. 
  4. Hello Cosmin,


    I tried for many times what you’ve suggested, but nothing happens. I send CR command as dec.19, and I tried to send the at command not only as string, also as ASCI characters. But nothing changes. DSP still receives what it sent in cross cable connection. Do you have any other suggestion for me to try?




    1. Code looks correct with char sendCR = 13; check on PC if you are really sending only AT#SHDN/r (8 chars), use a serial port monitor software (HHD free serial port monitor).

      1. Hello Cosmin,


        I solved the problem and it was about different reference ground connections of 2 individual boards. When I connect both grounds to eachother , the communication started to work. Maybe it is good to know that about EVK2, ground of 5-40V power input is not in short connection with ground of rs232 and the other ground points in the circuit, that was the problem.


        Thanks for the help..